Rooted my Incredible yesterday...with relative ease...some very helpful guides out there.

After searching a little...I can't find anything similar to my issue, and the pieces I can find don't piece together for me.

Was accessing hboot (power plus volume -) this morning and accidentally hit the power button to select "fastboot", rather than the "recovery" option i was wanting to get to to make another backup since I had added a few apps after my root.

My phone booted into froyo without any issue...and all my rooted apps worked fine (mainly wireless tether...the main reason I rooted). I shut down the phone and attempted to access hboot again...but got 5 vibrates and a green blinking led, with a blank black screen.

Pulled the battery...and let the phone boot normally (which I was hoping for since I thought I may have bricked it) and all is well...still with root applications working fine. I have tried hboot again with same result (5 vibrates and green flashing led), so I have let the phone stay with froyo for fear that if i screw around with it too much I may brick it after all.

Am I over-reacting to the lack of hboot? Suggestions for a fix are appreciated!