PDA

View Full Version : SD Card Problem (?)



dragongunner
02-07-2011, 03:11 PM
Hi all,

I am experiencing a problem possibly with my SD card and would love some advise.

Recently I got on board with CM7 nightlies. Since that time I have not flashed any other roms until today.

When I tried to restore a previous rom saved on the SD card (micromod gingerbread) the restore got to the point of sd card...app-private and would get frozen at that point. I had to do a batt pull. I then tried to restore again but this time to miui. Same problem freeze at the same location, but when I tried to restore CM7 nightly the phone did not freeze up and successfully restored my cm7 nightly.

I then downloaded nightly #34 and installed it without issues. I then tried to backup using clockworkMod and during the backup the phone froze on at sd card again.

Does this sound to you guys/gals that I have a problem with my sd card? Has anyone heard of this problem? It just seems that I can backup my current cm7 nightly or restore any other rom other than the CM7 nightly I saved previously. Also when in recovery the usual green lettering is now in orange. Is this correct or was this a part of the clockwork mod update to v3.0.0.7?

temasek
02-09-2011, 09:09 PM
Hi all,

I am experiencing a problem possibly with my SD card and would love some advise.

Recently I got on board with CM7 nightlies. Since that time I have not flashed any other roms until today.

When I tried to restore a previous rom saved on the SD card (micromod gingerbread) the restore got to the point of sd card...app-private and would get frozen at that point. I had to do a batt pull. I then tried to restore again but this time to miui. Same problem freeze at the same location, but when I tried to restore CM7 nightly the phone did not freeze up and successfully restored my cm7 nightly.

I then downloaded nightly #34 and installed it without issues. I then tried to backup using clockworkMod and during the backup the phone froze on at sd card again.

Does this sound to you guys/gals that I have a problem with my sd card? Has anyone heard of this problem? It just seems that I can backup my current cm7 nightly or restore any other rom other than the CM7 nightly I saved previously. Also when in recovery the usual green lettering is now in orange. Is this correct or was this a part of the clockwork mod update to v3.0.0.7?
I have read nothing but bad things about RM & CW. Maybe its time u use Amon_RA Recovery instead. But note their nandroid backups are not universal. It has to be restored with their respective recoveries.

Galloway
02-09-2011, 10:34 PM
I am actually experiencing the exact same problem right now!
I am trying to go back from LeoGingerbread to MMGingerbread v.20. I get to "Restoring sd-ext" and then it freezes, tried leaving it 15min and nothing. I have had to do battery pulls as well. Not sure if SD card ext is damaged or what...I may try and do an advanced restore and not restore "sd-ext" then use Titanium to restore apps that were in sd-ext. I'll let you know...

Galloway
02-09-2011, 10:47 PM
I got all my apps back that way but my status bar at the top is missing...no time, no date, no notifications or anything....I just tried flashing recovery back to 2.5.1.4
and will try a recovery that way...if not I guess fresh install and hope.

Galloway
02-09-2011, 10:59 PM
Ok so I got past sd-ext using 2.5.1.4 But there was still some wonkiness..no status bar still. I did make the backup using 3.0.0.5 though. I am now trying to install a backup that was made using 2.5.1.4 about 1-2 weeks ago, I also made sure to do the 3 wipe rule on everything except sd-FAT, we'll keep our fingers crossed and see...

Galloway
02-09-2011, 11:10 PM
No go...still no status bar or home screen also no apps unless I run TB...WTF! I'm gonna backup my sd card to the PC and then format the card entirely

Galloway
02-09-2011, 11:27 PM
Ok so far I have found that my SD-EXT was for some reason formatted to EXT4, I am positive I had it formatted to EXT3, When I flashed LeoGinger somehow it must have formatted SD EXT to EXT4, I reformatted it to EXT3 and and trying to restore a backup now...

Galloway
02-09-2011, 11:36 PM
That sort of worked. i now have a all my apps after a restore but my status bar is still gone...:confused: Anyone have any suggestions?

Galloway
02-10-2011, 12:03 AM
Ok really frustrated right now! I even did a full wipe and clean install and I still have no status bar at the top of the screen at all...WTF! How can it still have no status bar after a clean wipe and install?

dragongunner
02-10-2011, 10:11 AM
I posted this problem over at XDA a few days back and I got this response from rugmankc:

"I have those issues too. Recently, after a while of flashing nightlies, I tried to restore an HD Micro rom and also flash an eVil HD rom. Both failed. Reformatted and partitioned the sd card, problem solved.

This is not the first time. Seems like, for me anyway, the HD roms and roms like CM and MIUI handle a2sd/DT differently and may mess up the sdext. Not sure."

I personally have decided to just stick with nightlies for a while, but when I do feel the urge to flash something else I will do as rugmankc has advised. Hope this helps bro.

baseballfanz
02-10-2011, 12:34 PM
I had major problems last night
I think it's the new CWM 3.0,
It messed up the EXT partition and all hell broke loose.
CWM will flash and backup a ROM fine but when I went to do
a restore, that's when I ran into similar problems like you're describing.
Finally tracked it down to DT A2sd, if it's install that's when I get all these problems, not install it's fine.
So I partition my sd card again and after that it's working.
I had to do a full wipe and start from scratch.

From now on it's Amon Ra for me.:D

dragongunner
02-10-2011, 12:47 PM
Baseballfanz,

I agree. I believe the problems began once I upgraded rom manager. Problems began after that. I will re-partition my sd card today.

I have never used Amon-ra but will look into it also.

Another question, did your recovery change its looks? Mine went from the normal green lettering to bright orange-ish.

dragongunner
02-10-2011, 02:25 PM
Re-partitioned my sd card through rom manager. Everything is working as it should for the time being. :)

Snickolaz
02-10-2011, 02:36 PM
My SD card screwed up yesterday too. Not sure what happened, it could have been my own fault. But I noticed my phone rebooted and got stuck at the boot screen, so I pulled the battery and when my phone booted back up it didn't see the SD card at all. Turns out I pulled the SD card out slightly when messing with the battery. Then my phone didn't see the ext partition or something... Tried several things that didn't work, then finally I ran "a2sd reinstall" from adb shell on my computer. Phone reset and all was working again! Screwed with me for a while...

baseballfanz
02-10-2011, 08:52 PM
Baseballfanz,



Another question, did your recovery change its looks? Mine went from the normal green lettering to bright orange-ish.
Yes the 3.0.0.5 is orange not green.


Sent from my Nexus One using Tapatalk

Galloway
02-11-2011, 05:44 AM
I formatted and repartitioned my SD card as well, did fresh install and all is good now as well. I also changed to RA recovery instead of CW...don't know if I will go back after this little fiasco.

temasek
02-11-2011, 05:53 AM
Not too sure if its the commit in RM/CW for passion where it adds support to ext4. After this commit I am hearing problems about such issues u guys having.

hmm maybe the commit is for some other stuffs but mentioning passion & ext4, i smell smoke............... :FIREdevil:

aseems
02-11-2011, 06:49 AM
:yikes: you guys scared me back to CWM 2.5.1.4

baseballfanz
02-11-2011, 09:10 AM
:yikes: you guys scared me back to CWM 2.5.1.4
Better safe than sorry.:D


Sent from my Nexus One using Tapatalk

Galloway
02-12-2011, 09:39 AM
:yikes: you guys scared me back to CWM 2.5.1.4

Rightfully so! Infact I scared myself enough with it I ditched CWM and flashed AmonRA instead. So far it is working great and I don't know if I'll go back to CWM unless there is a very compelling reason. My compelling reason for going to AmonRA was the fact I hardly slept the other night while trying to recover my phone! Don't want to go through that too many times if possible...

Best advice...make sure to periodically back up the contents of your SD card to a PC or server so you can later restore them if needed.

dragongunner
02-12-2011, 10:44 AM
When you guys switched over to Amon_ra did you do it through rom manager where it says you can switch recoveries? Is this method a good way or should I find a zip someplace and flash it?

*Never mind. Doing it through rom manager.

baseballfanz
02-13-2011, 08:02 AM
How do you delete unwanted nand backup files with Amon Ra?

Sent from my Nexus One using Tapatalk

temasek
02-13-2011, 08:32 AM
How do you delete unwanted nand backup files with Amon Ra?

Sent from my Nexus One using Tapatalk
Just delete the nandroid backup sub folder. Each backup is under sub folder named BCDEAS-yyyymmdd-time

baseballfanz
02-13-2011, 10:35 AM
How do you delete unwanted nand backup files with Amon Ra?

Sent from my Nexus One using Tapatalk
Just delete the nandroid backup sub folder. Each backup is under sub folder named BCDEAS-yyyymmdd-time
Thank you :greendroid:

dragongunner
02-13-2011, 12:33 PM
When I was with 3.0.0.5 I reformatted and repartitioned my sd card. I thought it corrected the problems but it did not.

As soon as I reverted back to 2.5.1.4 and all the issues that I was having ceased completely.

I suggest to anyone still out there running with 3.0.0.5 to do the same if experiencing problems.

rugmankc
02-13-2011, 08:12 PM
When you guys switched over to Amon_ra did you do it through rom manager where it says you can switch recoveries? Is this method a good way or should I find a zip someplace and flash it?

*Never mind. Doing it through rom manager.


FYI--it doesn't come in zip, but .img

Fastboot thru ADB or flash_img thru Terminal Emulator--I have syntax if you want to do it that way. I had to cause the latest Amon just became available on RM. Before that it was 1.7.1.1?--For a long time. Gave up on CW and RM.


Ken

dragongunner
02-13-2011, 09:58 PM
When you guys switched over to Amon_ra did you do it through rom manager where it says you can switch recoveries? Is this method a good way or should I find a zip someplace and flash it?

*Never mind. Doing it through rom manager.


FYI--it doesn't come in zip, but .img

Fastboot thru ADB or flash_img thru Terminal Emulator--I have syntax if you want to do it that way. I had to cause the latest Amon just became available on RM. Before that it was 1.7.1.1?--For a long time. Gave up on CW and RM.


Ken

Thanks Ken but never mind. Since I rolled back to an older version of CWmod all seems to be working just fine. Guess I am still a creature of habit with some things.

rugmankc
02-13-2011, 10:12 PM
OK,

I think I still have 2.5.1.4 of CW, believe that is the number.

Worked great when I was using it.



Ken