PDA

View Full Version : I want to back up my N1 before HTC repair, Need to root?



FlyingsCool
05-07-2011, 04:03 PM
Hi,
My phone was run over by a car and the glass needs to be replaced (phone works fine). I'm about to send it to HTC for repair, but want to back up my installed applications because a lot of the applications I use are old versions and I don't want to upgrade to the latest versions if they erase my phone during repair.

I've never rooted the phone before. It has GB 2.3.4 installed. I'm running Windows 7.

What are my options?

Can I back up my system without root access?

If I need root access, can I get root access on a Nexus One that is on 2.3.4 and has never been rooted before (and has no custom recovery)? Is there an instructional thread out there for my situation?

I tried http://www.nexusoneforum.net/forum/nexus-one-development-hacking/10940-simple-sdk-setup-manual-root-guide-windows.html, but the process doesn't seem to work. I did seem to get the sdk installed. But when I run "adb devices" in the windows 7 command prompt window from the sdk\tools directory, the "list of devices attached" is blank. But if I run fastboot devices, it lists my device.

I'm not all that interested in rooting, I have enough to do in my life without having to further my addiction to my phone. I have a hard enough time putting it down now, I can't begin to imagine all the time I'll spend if I start fooling around with all the versions of android roms out there. I'm afraid my fiance might consider leaving me. :( lol But it is really important to me to back up my phone before I send it to HTC.

FlyingsCool
05-07-2011, 04:30 PM
oops, nevermind. I think. It seems to be working now. I didn't realize I had to reboot the phone after installing the SDK to normal mode. Or should I have rebooted the phone back into fastboot mode?

I was able to push all the files, change permissions, and GingerBreak is running now (?). Been going for a couple of minutes.

The instructions need a little more detail.
- What should I see after I run "adb devices"? Now I know, but it was confusing.

- Need to tell user what to do inbetween installing the SDK and going on to the instructions in the next post.

- A complete list of what should happen when running GingerBreak should be shown. So far my cmd window shows

[**] Gingerbreak/Honeybomb -- android 2.[2,3], 3.o softbreak
...
[+] Plain Gingerbread mode!
[+] found system: 0xafd17ea1 strcmp; 0xafd37b35
[+] Found PT_DYNAMIC of size 232 (29 entries)
[+] Found GOT: 0x00014344
[+] Using device /devices/platform/goldfish_mmc.0
vold: 0063 GOT start: 0x00014344 GOT end: 0x00014384

and now it is sitting there, no prompt yet, been waiting a few minutes. What's next?

FlyingsCool
05-07-2011, 04:37 PM
Ok, I reread the instructions. They do say to reboot into fastboot mode. But when I do that, adb commands don't work. If I run adb devices, the list is blank. I only see my device with the adb command if I boot into regular phone mode. As noted, in that mode, I was able to run all the commands and got the above result. Except it never came back to shell mode with a #. So I'm confused. Should I try to boot into regular mode and run the commands again and be more patient this time? I think I waited at least 5 minutes.

danger-rat
05-07-2011, 04:57 PM
The Gingerbreak exploit doesn't work for 2.3.4.

Your best option would be to use MyBackup Pro from the market...

FlyingsCool
05-07-2011, 05:45 PM
Thanks, just what I needed.
Ultimately, I would like to root someday. When I can find some time...

Anyone got any time I could have?

danger-rat
05-07-2011, 05:47 PM
Lol - have you tried eBay?

WERA689
05-07-2011, 09:37 PM
I have found that Craig's List has better deals on time :p

rugmankc
05-08-2011, 12:03 AM
Time is the Fire in which we burn!



~Delmore Schwartz,
"Calmly We Walk Through This April's Day," 1937

dudedidtheplan
05-08-2011, 04:47 PM
In the words of the great Tommy Chong on one of the Cheech and Chongqing albums. When asked if he wanted the buy a watch he said, " um.... I'm not in to time, man."

rugmankc
05-08-2011, 04:49 PM
Talk about hijacking a thread :rofl3: