View Full Version : Nexus one stuck at boot (X) screen

06-10-2011, 02:32 AM
I have been a very happy user of nexus one (with cyanogenmod) for more than one year.
I left the phone connected to power at bedside table with the water bottles while sleeping.
When I woke up, the screen of the phone was steamy and was off. I tried to switch it one but it did not.

So, I took out the battery and left the phone opened for drying.
After two days, it did switch on but it gets stuck at the first screen with colored X pic and lock symbol.

I have been waiting for more than a week but it does not seem to move forward. Though I am able to get to the recovery screen but when I try to recover it gets stuck again.

Do you think the hardware is damaged? Should I stop waiting and buy a new phone. I have bought a very cheap phone for time being so I can wait for a month.

Should I go to HTC support? I bought it in US and I am currently staying in India. Also, I have opened the phone once so seal "void" sticker on the screw has been removed. I had rooted it and installed cyanogen mod.
So, I am not sure if HTC guys will be any helpful.

Any suggestions?

06-10-2011, 03:03 PM
Well if the void sticker is off then you will need to pay for the repairs but there are a few other things you can try first.

One you said you tried flashing from recovery so I will figure it is a custom recovery did you try both nandroid restore and flashing a new ROM.

I would also try the passimg method and if your bootloader is unlocked then try fastboot flashing.

Also when it hangs at the :nexusx: do you get 7 vibrations.

06-10-2011, 04:26 PM
I had exactly the same problem today after trying to access recovery (AmonRA) from the bootloader menu. In the end, I connected it via Fastboot USB mode and "fastbooted" a stock Froyo image that I had from a while ago, it all worked fine.

You can follow this guide I wrote on XDA a while ago up to Step 13. You don't need the GRI40 Image, just simply type *#*#CHECKIN#*#* with Wifi connected after it boots into Froyo, wait a good 15 mins as it will download approx. 90mb in the background then notify you the latest update is available (Unless you want to root and go back to Cyanogen ofcourse). The guide assumes you have the latest Android SDK and know how to access fastboot from a DOS command line window.

Guide here (http://forum.xda-developers.com/showthread.php?t=1012382)

06-11-2011, 08:42 AM
what it indicates?
hi there.my phone stuck on x screen after attempt to flash an update from google. it hangs up, vibrates 7 times and thats all.
when i use passimg it says "main version is older"
when i try to flash by fastboot it says " signature verification fail"
is there's something i can do?

06-11-2011, 10:15 AM
Fastboot is failing because you need to unlock the bootloader to use fastboot.

Try this first (restore guide). There's a work around for the main version error...

06-13-2011, 04:56 AM
Dear All,
I am very happy to inform you all that it came back to life automatically.

Perhaps the water dried up.

Sandeep Giri

06-15-2011, 12:31 AM
hi there. just wanted to inform you that 7 vibrations is overheating cpu (at least in my case).i put the phone in the freezer for 2 min and it worked like new, for about 10 min more, and then stuck again.it makes sense that if the systems overheats it stucks to prevent permanent damage. there must be a hw problem with the phone, but at least i know where i should look. now i need to find a solution for keeping it cool without carring the freezer with me.