View Full Version : Strange error on "./fastboot-mac oem unlock'"

07-09-2011, 10:45 PM
Hi, I'm attempting to root my Nexus One. As far as I can tell, I need to do this to get privileges to use adb shell, or more accurately, most of the unix commands available on adb shell. I'm pretty sure I used to have them, but I believe the OTA update of 2.3.4 took away superuser access.

So, after doing some checking around on how to root, I've started working from this tutorial:

Video: How to unlock and root a Nexus One – Android and Me (http://androidandme.com/2010/01/hacks/video-how-to-unlock-and-root-a-nexus-one/)

But I am also planning to use recovery-RA-passion-v2.2.1.img and su.zip
as mentioned in this tutorial:

Root Nexus One with Android 2.3.3 Gingerbread | Chen Sun's blog (http://chensun.net/android-development/root-nexus-one-with-android-2-3-3-gingerbread/8/)

I would like to go with the second one completely, but because I'm running from a mac I have to sort of combine the two.

However, I've quickly run into a problem. For some reason, fastboot doesn't come with android-sdk for mac; so I downloaded a version from the HTC site here: HTC - Developer Center (http://developer.htc.com/adp.html)

And when I run this:

./fastboot-mac devices

I can see the phone as hoped; but when I run his:

./fastboot-mac oem unlock

It returns the error:

... INFO[ERR] Command error !!!

It seems as if other people must have pulled this off from a mac, but for some reason I've gotten tangled up in this unlock problem. Any ideas?

07-10-2011, 12:45 AM
I'm not much of a Mac user, but it looks like you are using the right commands so maybe there is something wrong with the actual fastboot util you are using?

07-10-2011, 10:37 AM
I'm not much of a Mac user, but it looks like you are using the right commands so maybe there is something wrong with the actual fastboot util you are using?

Hi Danger Rat,

The fastboot comes form the HTC, but it's a bit old, originally made for the G1 I think. There's a newer one I got somewhere, but it gives the same error. One option is to find the source and compile it; but I'd rather go down a route more well-traveled. I might try to fire up my VM, but it's really slow and last time I tried I got some kind of Windows error. i could also try it from my wife's windows system, but that is really slow too.

I'm very disappointed at what a hassle it is root the Nexus one! That was the whole point it buying it. Oh, well, I'll get there...

07-10-2011, 11:49 AM
Done a bit more digging, and I think you may have to correct fastboot util (seems to be the most common, at least)...

Let me start by saying that just because you are having some difficulties, it doesn't mean that the Nexus One is a hassle to root. It's one of the easiest phones to root, and it's that way by design...

Like I said, I'm not a Mac person, so I don't know the answers, but the error you are getting appears to originating from your Mac not from the phone. My guess was that it was the fastboot util, but it was only a guess and one that appears to be wrong.

Since you are following the right steps, I would try looking at each component:
1 - fastboot file (probably the right one, but it won't hurt to try another)
2 - Mac - doubt this is the problem, but having said that I guarantee I could unlock it on a PC in seconds, unless there is a hardware problem. Try another computer. It doesn't have to be a fast computer (the fastboot util is so basic).
3 - USB cable - it's very easy to try a different cable if you have one.
4 - Phone hardware fault - trying a different computer may help identify this.

If you do try a different computer, you don't need to install the SDK, you just need the drivers and the fastboot util (and adb, if you plan on using adb). The SDK is for developing software, not unlocking or rooting the phone...

07-10-2011, 03:55 PM
I tried downloading fastboot again, but this time it didn't even get as far as seeing the device. So, after trying Vista out on VMWare and getting stopped by there by a usb driver issue, I switched to my wife's home xp system. It's pretty low-end and slow, but I just decided to install the adk anyway. I was able to get the usb drivers installed and "adb devices" sees the Nexus one. However, fastboot, which is in the sdk tools folder, failed to run on a "WinApiDll not found" error. So, I took that from chensun's fastboot.zip at Root Nexus One with Android 2.3.3 Gingerbread | Chen Sun's blog (http://chensun.net/android-development/root-nexus-one-with-android-2-3-3-gingerbread/8/) and copied it into the tools folder. Once I powered the Nexus One into fastboot mode, the fastboot devices showed the device (for some reason I had to re-install the usb drivers - it maybe thinks it's a different device in fastboot mode). After that, I entered fastboot oem unlock, and it unlocked the loader - at last! From there is was just a couple of minutes to follow Chen's instructions.

Thanks for your help. Why fight city hall? it's better to unlock from a PC.