View Full Version : [Q] Help! Bricked or bad internal memory

07-16-2011, 12:19 PM
I am looking for guidance this time and have looked everywhere and tried everything.....I have a Nexus s I9020 (t mobile version) and a couple weeks ago I don't know what happened really but i may have been messing around with a newer version of clockwork recovery late one night .... then the phone wouldn't boot past the google screen and I couldn't do anything to fix it... I tried to figure things out the next day and this is a list of things i have figured out...
1. in clockwork it can't mount anything....like anything at all pertaining to the internal memory/storage
2. I was tired and irresponsible
3. I tried fastboot just about everything
4. I tried flashing newer/older versions of clock work......nothing worked
5. I have tried downloading and installing roms via adb and fastboot but an error message comes up...
6. now this I know is dumb on my part, but make fun of me as you will... I fastboot locked the device......I know it was stupid because now when I type in fastboot oem unlock it hangs and does nothing after I check unlock on the phone...
I can get into fastboot mode and it says no boot or recovery img?

now if I had access to the internal memory I would def. be able to go back to stock but there in lies the problem what on earth can i do to make this thing a paper weight?

this is what i'm talking about, the bootloader doesn't unlock it just hangs .... any thoughts?

07-16-2011, 01:35 PM
Google Nexus S i9023 hard reset - PDA Smartphone PNA hard reset soft reset (http://www.hard-reset.com/google-nexus-s-i9023-hard-reset.html)

Turn OFF the phone

Press Power and Volume UP buttons simultaneously

Using the Volume DOWN Button select the 3rd item in the menu that comes up

Then Press the Power Button to Confirm Nexus S i9023 Factory Reset


in the Menu

07-16-2011, 01:46 PM
Unfortunately I don't have that option I have the options reboot bootloader, reboot, recovery, power off .....and I can't get into the phone seeing as though there's no boot or recovery IMG? The strange part is clockwork is still somehow installed and working....well not really, I can't mount, format, or install anything through it.....I really just need to re unlock the bootloader at this point but whatever I try nothing works...thanks for taking the time to try and help though it is much appreciated

07-16-2011, 05:33 PM
You said you have a menu entry for Recovery?
But nothing happens when you try that?

Also, have you tried pulling your SD card out and trying some things?

I would also put that SDCARD into your PC and look for backups etc?

On my Nexus if I look at my SDCARD there are just some of the following places to look

Before you do anything copy the following directories to your PC someplace to make sure you have a backup of any files in those directories.


Also, in your file manager you "should" see a "trash" folder.

Copy & save that somewhere (if you are lucky any previously deleted files may be in the "trash"... just don't EMPTY TRASH...!

OR -- better yet copy your whole SDCARD to you PC somewhere.

Then use your file manager and go back to your SDCARD and

-- in there I can find any previous Backups I'd done using Cyanogenmod.
They will be named with the Date of the backup as part of the subdirectory name for each backup

07-16-2011, 08:00 PM
Unfortunately the nexus s doesn't have a removable sdcard this is why it was a dumb idea on their part now I'm screwed

07-17-2011, 07:17 AM
so by any chance are you a Linux users?

If so download & install the Android Software Development Kit (SDK).

After installing, plug your tablet into your PC with a USB cable.

From the PC type command:

$ adb devices

to make sure you see the android as the response should look something like:

$ adb devices
List of devices attached
emulator-5554 devicethen if it shows up
then type the command:

$ adb shell

if you are lucky you will be put into the Android's shell prompt.

From their you can change to superuser:

# su

do a "search" for the directory I mentioned earlier that holds the CyanogenMod backups (I the directory name was "backup"):

so searching FROM the 'root' of the Android file system the command would be:

# find / -name backup -print

If you are lucky you will see WHERE "backup" directory is located on your Nexus S

Then change to that directory

# cd /where-ever-it-is

List all files again:

# ls -la

Hopefully, there is at least one previous Backup directory listed.

If so I'd copy it (and all others) back to your PC using the "adb pull" command before doing anything else. That will mean first exiting the Android shell to get back to your Linux prompt:

just type 'exit' until you get back to your linux PC again and see a "$" prompt again.

# exit

then create a temporary directory somewhere on your Linux PC.

After that's done use the ADB to "pull" the files from the android to your PC

adb pull <remote directory path/file> <local directory path/file>

# adb pull /home/yourname/mytmpdir /android-path-to-backups/

See if you can get this far first.

07-17-2011, 10:39 AM
As soon as I'm home from work today I will give that a try ....I will keep you posted thank you again for this, it looks very promising