PDA

View Full Version : Nexus S wifi setting not using static IP



stickler
08-06-2011, 01:36 AM
Hello,

I have been a reader of this forum for last two months but joined recently only.

I am having a strange issue with my Nexus S (2.3.4)

Even if I set the static IP in WiFi settings, Nexus S still obtains the IP through DHCP. Has anyone experienced this problem?

Please help me to find a solution to this issue, it is quite irritating.

I tried restarting the phone but it was of no help!

Appreciate your help!

danger-rat
08-06-2011, 11:57 AM
What are your router settings?

stickler
08-15-2011, 02:59 AM
Hello,

I have disabled DHCP in router. Now, the setup is as below.

1) Laptop running Win XP is connected to internet using USB modem. Internet Connection Sharing is enabled over WiFi

2) Laptop is connected to Netgear WiFi router in which DHCP is disabled.

3) Now, when I try to connect Nexus S to this router, it receives IP address over DHCP from Laptop DHCP server and it is not able to access internet.

I have tried this same setting before also and it worked flawlessly. Recently I am noticing that Nexus S is never using the static IP assigned to it!!!

Any suggestion for a way out will be appreciated

Thank you.