PDA

View Full Version : Nexus S Won't Turn On



shawn10
09-07-2012, 03:44 AM
I updated to Jelly Bean 4.1 a few weeks ago. The phone was a little laggy, there was a lot of stuff on there and the battery was draining quickly. After doing a search on the internet, lots of people suggested I do a hard reset. I did a soft reset first. Then when that was done, I rebooted the phone to do a hard reset, but didn't press the right key combination, so the phone booted as normal. I decided I didn't want to wait for it to load up, so I took the battery out to restart. When I put it back in, the phone wouldn't turn on. I tried my second battery, I tried charging it, I tried taking it out and waiting a few hours, nothing would work. After leaving the battery in the phone for a couple hours, I noticed the phone was getting pretty hot and it still wouldn't trun on. What is up with that, anyone has any ideas?

cmdrtomalacc
09-12-2012, 09:12 PM
If you know how to boot into recovery, do that. Scroll down to "wipe data/factory reset" and press power button. I had this problem once on my Nexus One, worked like a charm.

cmdrtomalacc
11-03-2012, 01:14 PM
Well, if it's moisture, the forum can't really help you much. I suggest upgrading to a newer nexus or buy a nexus one from Ebay (really cheap).