PDA

View Full Version : [SOLVED] Nexus Does Not Show in MTP Mode in Windows Explorer



HAB
10-30-2013, 08:55 AM
Looking for help to the following problem: When I connect my nexus 5 or nexus 7 via usb to my computer I no longer can see them in "my computer". Windows notifies that a device is connected and recognized. USB debugging is on. I do see them in PTP mode, but not in MTP which is what is needed to transfer files. I've tried uninstalling and reinstalling the nexus drivers, no change. I've had no such problem until recently. Any help would be greatly appreciated.

cali
10-30-2013, 12:04 PM
Just wanted to welcome you to the site. Hope you get this worked out.

UltraDroid
10-30-2013, 12:40 PM
Hello HAB and welcome to the forum. If you can hang on a bit, one of our more knowledgeable members or staff will be by to give you a hand. :)

HAB
10-31-2013, 09:49 AM
I found a solution at xda, in case others need assistance: 1. Enable USB debugging: Go to phone settings -> About -> Tap build number repeatedly until developer menu is enabled. Go there and tick USB debugging.
2. On your PC, go to your device manager (when the Phone is plugged in and set to MTP), locate the phone, right click on it -> properties
3. go to the Driver tab
4. click Update Driver
5. click Browse my Computer for driver software
6. click Let my pick...
7. select USB Composite Device
8. finish up with the assistant

cali
10-31-2013, 08:18 PM
Thanks for returning and posting the solution.

WarriorDad
07-31-2014, 02:06 PM
Thanks SO MUCH for providing the solution!!! This has had me stumped for weeks!!!

jhemming
08-24-2014, 09:51 AM
Thank you!!!