View Full Version : How To Re-Enable Disk Encryption/Use Password With TWRP?

02-09-2017, 03:28 AM
I have a LG G5 H850, with 6.0.1 and stock V10c-EUR-xx.

I disabled disk encryption using the no-verity-opt-encrypt.zip utility by jcadduono.
Now I wiped again using TWRP, but encryption is still disabled as the boot.img/partition still has his modifications to the fstab files (where he does
the change s/\bforceencrypt=/encryptable=/g etc.)

How to I set that back to as it was?

I got into this sitation as I kept finding TWRP could not access the partition - asked for password and there was none.

I do want to use encryption but in my first hour of setting up the phone I had a problem where when I booted into TWRP it would ask for a password and it was not "default_password", and I had not set anything and never used lock screen/pin etc. I tried setting a lock screen/boot screen password - the phone worked but TWRP could not access the filesystem. I tried the cryptfs application and still TWRP was not able to decrypt/access the partition.

Then I tried a terminal with vdc cryptfs changepw command and that just locked me out of the phone completely, as the new or old boot password would not work.

So I went for the no-verity-opt-encrypt.zip solution - but I dont want an unencrypted phone either. Now I want to try encryption and TWRP again - this time setting a pin at the first setup screen opportunity to see if that gets set as the password that TWRP could use. However I can't remove the disable encryption patch!

Ideally I am trying to get to a setup where:
encryption is enabled
I want to be able to boot TWRP and access the encrypted filesystem and install more zip files such as xposed/supersu updates etc anytime in the future.
I dont want to use the "no-verity-opt-encrypt.zip" patch.
I do not want TWRP to be locked out from modifying the encrypted system partition.

Additionally, I havbe not been able to install xposed using TWRP and the zip file (dl-xda.xposed.info/framework/...dk23-arm64.zip) .
In TWRP it installs, I dont see any errors, but on boot up I have no xposed icon. I have been able to install it by downloading the apk and installing as an untrusted source, not sure if there is something wrong in having to do it this way?