PDA

View Full Version : SDK location



KansaiRobot
03-03-2011, 12:39 AM
I tried to create my first appli today but i got the following error message:

"set the SDK location"

But when i go to preferences in eclipse, and i enter the android-sdk-windows folder it complains that it cant find the adb.exe

Of course it cant find it! The new version does not have it on the tools folder but on the platform-tools folder!

How can i make eclipse understand that!?:android-question:

RayBan
03-12-2011, 09:34 PM
Well, I know of one thing that would fix this problem and the whole lot of future issues you will probably have by devving for android on windows.... switch to LINUX! :D

The Linux system is particularly suited for development, especially on android. There are a bunch of distros out there, but I personally recommend Ubuntu 10.10 64-bit. It's phenomenally fast, easy to use, easy to dual boot on a Windows computer, and has phenomenal community support.

I know that's not the answer you were expecting, but Android is Linux-based so they literally are built for each other. Also, you never know.... Linux might just put your Windows to shame! :)

Sent from my Droid using Android.net App

Droid-Xer
03-13-2011, 04:21 AM
Have you tried putting all the tools in platform tools? For adb I just put everything there for it to work. Otherwise I get issues. Just a guess. And ya ubuntu 10.10 is pretty sweet.

RayBan
03-13-2011, 09:45 AM
Have you tried putting all the tools in platform tools? For adb I just put everything there for it to work. Otherwise I get issues. Just a guess. And ya ubuntu 10.10 is pretty sweet.

+1 good idea -- I think the OP would instead need to put everything in the tools folder for it to work, since the problems they are having arise from the platform-tools filepath. But yeah that should work if you can get eclipse to work on the tools folder instead.

Correct me if I'm wrong ... bc Windows is not my forté lol

Sent from my Droid using Android.net App

Droid-Xer
03-13-2011, 06:01 PM
For me I put everything I need in platform tools to work using vistax86. I couldn't get drivers to work on ubuntu or win7 64bit.