PDA

View Full Version : Mail Sync Schedule Problem



ptobey
11-22-2011, 10:42 PM
I've had the Amaze for a couple of weeks and am seeing a behavior that I can't correct or find a root cause:

I have three Mail accounts: one Exchange based, one POP/SMTP, and one Hotmail. Periodically during the day, one or all accounts will fail to sync at their configured rates. Exchange is set for push, POP for 1/hour, and Hotmail 1/hour, on a schedule between 6am and 9pm, and manual otherwise. During the day, I'll check the Mail app and find that, for example, POP hasn't synced since "Yesterday" or three or four hours ago. I've removed and recreated each account, hard-reset the phone, and tried various settings with no effect. Can anyone suggest a cause or a possible fix? I'm running the updated HTC image from a couple of weeks back.

Thx!

Sent from my HTC_Amaze_4G using Android.net

Alexandrite
12-14-2011, 01:45 AM
Online email accounts of gmail, hotmail, and yahoo have NEVER updated correctly since day one of owning the Amaze. I even made it so that it would refresh/update every 15 minutes. I've deleted and re-installed each account. I've also checked all syncing settings online with gmail, hotmail, and yahoo; there was NO REASON THIS SHOULDNT WORK!!

Once I read and delete an email it doesn't get updated on the Amaze. And vice versa-- once I read and/or delete an email on the Amaze it doesn't update the online accounts. AUGH!! :android-cry:


Please be the solution to the HTC's techs saying... well, you should do a hard reset back to factory settings. WHAT A TERRIBLE ANSWER!

MeowMixMakesMeDoTricks
12-14-2011, 07:18 AM
I know changed power saving settings can affect the updating of background data. Do you have any of those accounts on another android device?

Sent from my VM670 using Android.net

ggraysonlv
10-12-2012, 04:57 PM
I share your pain. This problem infuriated and confounded me for a couple of weeks too, when I got my new Amaze 4G. I thought I had checked every possible setting. Yesterday, I found the culprit in my case; maybe it is the same for you, too?

On the phone, when you drill down from the Home screen (with Menu button) to the Settings / (scroll down to) Account & sync page, this is where all of your mail accounts' settings are tweaked. STOP! - don't drill down into Exchange ActiveSync. Instead look at the top right of that screen. There is a rather tiny, unobtrusive, easy to overlook (I didn't see it until my THIRD visit to this screen) "slide switch". You have to turn on Auto Sync with this slide. Note that all your account's sync icons are now lit up. Problem solved? It is for me. I think the Android 4.0.3 factory setting must be OFF for this slide switch, although for what reason I can't imagine.