View Full Version : I may have bricked my HERO2000 trying to flash a custom ROM.

09-20-2010, 03:27 AM
I'm new to this whole flashing custom ROMS business. I have a CDMA HTC Hero 2000 and I downgraded to the original 2.1 before the update just fine, rooted my phone just fine. Then I tried to flash Aloysius to it using instructions I found here: [Complete Guide] How To Flash A Custom ROM To Your Android Phone With ROM Manager + Full Backup & Restore | Android News, Reviews, Applications, Games, Phones, Devices, Tips, Mods, Videos, Podcasts - Android Police

After all was said and done, my phone starts to boot with the "HTC quitely brilliant" logo, following by "SPRINT the Now network" logo and after it shows "Now" for many seconds (as it normally does before pulling up the home screen), it reverts back to the HTC logo and repeats this process until I remove the battery.

I removed the microSD and attempted to boot, same thing. Then I held down HOME+BACK+POWER to do a manual hard reset, this took a little longer but again had the same result.

I may just cry now. Please help! :(

09-20-2010, 03:31 AM
Chris did you do a nand backup before you flashed? You didn't brick your phone you are in a boot loop. It can be fixed dont worry. The process depends on if you did a backup or not.

09-20-2010, 03:36 AM
no I did not. I was thinking that I just wiped everything off my phone so a backup would not be necessary. clearly I was wrong. so what's next?

09-20-2010, 03:52 AM
Ok well i dont need to tell you now but first thing you do when flashing anything is a backup. Now first thing i would try is reflashing the rom. Boot the phone into recovery.
1. Pull the battery
2. There is a combo of buttons to boot your phone into recovery. On the Evo its power and volume held until the phone boots. Not sure what the buttons are on the Hero.
3. Select recovery
4. flash zip from sd card
5. select zip
6. go to Aloysius and select
7. boot
Follow these steps and see if it fixes and let me know

09-20-2010, 04:00 AM
did exactly that. home + power brought me to the screen you mention.

advanced option
recovery reboot
install aloysius.zip

still looping. :confused:

thanks for helping me with this, I hope to get it running without tyring to make up some story to sprint or HTC.

09-20-2010, 04:08 AM
Ok next thing i did (yes i did the same thing on my phone) find another rom on the internet. Take your sd card out of your phone and mount into the computer and put the new rom into the root of your sd card.

Remount your sd card and do the recover process again this time selecting the new rom you loaded.

Just a few questions
1 when you moved the rom to your sd did you leave it in the zip format?
2 when you put it on your sd did you put it in a folder or on the root of the card?

09-20-2010, 04:12 AM
We're here for helping. Dont worry yet lol if we cant get it tonight the other mod on this site is a little more well versed in this. He's MetalHead and like me he's here on and off all threw the day.

09-20-2010, 04:15 AM
word, well I appreciate it a lot. I have to pick up a micro sd reader tomorrow at work and then i'll try that. i'll reply when i'm there.

09-20-2010, 04:19 AM
No problem Chris. Also look up how to flash a custom rom on youtube. to see the process helps too.

Hit us up tomorrow we'll get it working

09-20-2010, 08:57 AM
You definitely didn't brick your phone so no worries there.

Try booting into recovery, do a full wipe, then wipe your cache partition and your dalvik cache (twice for good measure) and then reflash the ROM.

If that doesn't work then you could try flashing a different kernel over the ROM. What version of the ROM is it and what kind of kernel comes prepackaged? If it's an OC/UV kernel then there is always a chance that your phone just doesn't like it. Try finding a different kernel that's not OC'd, and then try flashing that over the ROM. Clear your cache and dalvik before flashing the kernel.

09-21-2010, 03:36 AM
Didn't get a chance to get on here until now but I fixed it last night.

I did this by going back into reboot recovery mode (by pressing HOME and POWER), going to partition settings, COMPLETELY wiping everything on the sd card, mounting the USB and dragging a new ROM .zip file onto it. (I tired this twice without completely wiping and the phone continued to have problems booting.

The flash worked fine that time and all has been well. Turns out the first one I was trying to apply to it was just an upgrade.

Thanks everyone for your help, makes perfect sense now.

09-21-2010, 09:27 AM
Hey Chris glad you got it worked out