View Full Version : Dell XCD28 Stuck on Dell Logo / FTM

06-22-2012, 06:40 AM
When I switch on my XCD28, it hangs on the Dell logo screen.
When i press power button and down volume key (as suggested on many forums), it gets stuck on FTM white screen.

What do I do?

06-22-2012, 06:48 AM
have you tried pulling out the battery,SD, and ext memory (if it has any) card then just insert the battery and try the hard reset again.

06-23-2012, 02:53 PM
Thanks for your quick response. Yes I have tried that.

06-23-2012, 03:35 PM
Can you try and boot the phone in recovery mode and perform a factory reset?

-end of line-

06-27-2012, 01:12 AM
How to boot the phone in recovery mode?
I have tried switching on the phone in probably all the combinations possible with no result, i.e.
Home + Up Vol + Power
Home + Down Vol + Power
Menu + Up Vol + Power
Menu + Down Vol + Power
Up Vol + Down Vol+ Power

Only thing that happens with Menu key combinations is that the Dell logo comes with an animation, but then it gets stuck in the same manner.