Hello,
I am new to Android development. I have some confusion on using support library V4 and V13.
What is main difference between these two versions?

For example:
1. I want to develop one application that should run on various devices from [Android1.6 API-4] to [Android4.1 API-16].
Should I use support library V4 or V13?
2. What should be android:targetSdkVersion and android:minSdkVersion if I want to use V4 support library?
3. What should be android:targetSdkVersion and android:minSdkVersion if I want to use V13 support library?
4. I still does not understand if v13 requires 13+ devices why is it a superset of v4 (Android Support Package / Compatibility Library - use v4 or v13? - Stack Overflow).
5. Upto which android:targetSdkVersion, V4 gives support?