My google contacts are synced to my phone. But now, everytime I send an email to a new email address, that address is added to my contact list on the phone. I don't want to save these addresses into my contact list. I'm sure I have some setting wrong, but I haven't found it yet. Can anyone help. Thanks.