There is a fix for this issue. I use Google Apps Premium and had to change my email settings from POP to IMAP. If you do this, remember to go into the Cloud and disable POP and enable IMAP or your phone won't take the new setting. Hope this helps and I'm amazed Sprint hasn't come up with this fix.