EVO 4G Dead Pixels?

This is a discussion on EVO 4G Dead Pixels? within the HTC EVO 4G forums, part of the HTC Android Phones category; I got mine at Radio Shack. First thing I told the manager was "i want to make sure there are no dead pixels." I've had ...

Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: EVO 4G Dead Pixels?

  1. #21
    Junior Member nacronig's Avatar
    Join Date
    Jun 2010
    Posts
    3
    I got mine at Radio Shack. First thing I told the manager was "i want to make sure there are no dead pixels." I've had them too many times in LCD screens over the years. He wasn't too thrilled with me. Oh well.

  2. #22
    Junior Member no4Gyet's Avatar
    Join Date
    Jun 2010
    Posts
    1

    Dead pixels... twice

    I purchased my EVO at a Sprint Store on the 4th. Before I took it home, I noticed a dead (red) pixel in the lower left quadrant. They told me to keep the phone til they had more in stock so they could swap it. The pixel did turn to blue a few days later, but I still wanted to swap the phone.

    Swapped the phone this evening. Looking at the phone once I got home, there are 2 pixels stuck on green, this time in the lower right quadrant.

    2 phones in a row. Awesome. Don't stand next to me, might get struck by lightening.
    Attached Images Attached Images  

  3. #23
    Senior Member rich_c's Avatar
    Join Date
    Jun 2010
    Posts
    261
    Can't see any on mine. Maybe I better not look too hard. LOL

  4. #24
    Android Lurker droidhead's Avatar
    Join Date
    Jan 2011
    Posts
    0
    Thanked
    1 times
    2 phones in a row. Awesome. Don't stand next to me, might get struck by lightening.
    If it makes you feel any better, my first evo had the screen separation problem, and the so does the replacement that I just got from Sprint. I'm going to hang on to this one until a newer batch comes out with hopes that they will rectify the issue.

  5. #25
    Junior Member totlco's Avatar
    Join Date
    Jun 2010
    Posts
    1

    Stuck pixel

    No dead pixels, but a stuck one...my Evo is 2 weeks old

  6. #26
    Junior Member sully's Avatar
    Join Date
    Jun 2010
    Posts
    9
    Well my luck ran up again, for the second time. My replacement EVO just started forming a blotch of dying pixels about a week ago. At first I didn't notice it and now any time I have a white background, it's very apparent.

    Hard to capture on camera but here's a shot.


Page 3 of 3 FirstFirst 123

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

evo 4g green dots on screen
,
evo 4g green stain on screen
,

evo dead pixels

,
green dots on htc evo 4g
,
green mark on htc evo 4g screen
,

green spots on htc evo

,
green spots on htc evo 4g screen
,

htc evo 4 display has green spots

,
htc evo 4g dead pixels
,

htc evo 4g green dots on screen

,
htc evo 4g,some green spot over the screen?
,

htc evo green dots on screen

,
htc evo green spots on screen
,
htc evo has green dots on screen
,
my htc display has green marks
Click on a term to search our sites for related topics.
Android Forum