while trying to downgrade I accidentally installed the AT&T update ERE36B and I have a T-mobile phone. I am now trying to downgrade to ERD79 but when I try to flash it I am receiving an error that says "main version is older!" when trying to passimg.zip the stock rom. I am not sure if it has any relevance but when I choose the recovery option there are a few errors that pop up before moving on to the next menu. They seem to be searching for a passimg.zip but say it is not found.