MMS Not working on O2 in uk

This is a discussion on MMS Not working on O2 in uk within the Nexus One Tech Issues / Bug Reports forums, part of the Nexus One category; until you find something that works i suggest emailing the pictures,personally thats what i do as i dont remember the last time i needed mms ...

Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: MMS Not working on O2 in uk

  1. #11
    Senior Member tonybhoy's Avatar
    Join Date
    Mar 2010
    Posts
    981
    until you find something that works i suggest emailing the pictures,personally thats what i do as i dont remember the last time i needed mms lol

  2. #12
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    Managed to get to the bottom of this issue. I tried sending a tiny pic and it worked. Therefore the size of the photos I am taking must be too large for O2. Question is, now I have to do the whole Mancunian thing in order to find out what the max size I can send and receive, I don't fancy my chances.

    Also, I tried handcent but to no avail, still couldn't send.

  3. #13
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    With handcent did you adjust the settings to try to spoof as an iPhone? Go into settings, verify "Maximum MMS size" is set to default (300k) and change "Custom User-Agent" to iPhone (3.0). Maybe that will trick the O2 network into thinking the MMS is coming from an iPhone instead of an 'unsupported' model...

  4. #14
    Android Lurker ceramista's Avatar
    Join Date
    Jan 2011
    Location
    Lisbon, Portugal, Portugal
    Posts
    1
    I also canīt get MMS to work for me here in Portugal.
    Everything else works fine.

  5. #15
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    It seems that most of these MMS issues are a function of the following:
    1. having the correct APN settings for you carrier
    2. your carrier including support for the N1/Android on their network.
    3. the size of image/media you're trying to send.

    First and foremost, make sure you have the correct APN; I think the entries are case-sensitive. You'll go here on your phone to edit your APN:
    Settings>Wireless & networks>Mobile networks>Access Point Names
    If you don't have the APN info for your wireless carrier, you could try to contact them to get it or the info could potentially be listed here:

    APNlist - cyanogenmod - page to maintain an accurate working list of APN's for cyanogen (and other?) builds. - Project Hosting on Google Code

    If you're certain you have the right APN info, try the Handcent 'custom user-agent' spoof trick. As I mentioned before, you can employ the Custom User-Agent setting in Handcent (also in custom roms, see below). Most wireless carriers set the maximum MMS size to 300k, so be sure that's set correctly.

    **Everything from here down is for rooted CM users**
    This may work in other roms, but CM is the only one I know about.
    If you're running CyanogenMod 5.0.5.x and experiencing MMS issues not related to your APN settings, there should be a similar custom user-agent spoof setting in the stock messaging app, so you may not need Handcent.

    However, there seems to be an known issue with image resizing in the Mms.apk included in his v5.0.5.x rom which will allow an oversized image to be sent...one that will exceed the 300k threshold. You can either try the newer Mms.apk from the v5.0.6 rom which appears to have the issue fixed...it's attached to this post; change file extension from zip to apk.
    -or-
    you can modify you current Mms.apk with your own image size settings using the instructions outlined in this article...you'll need a hex editor for this:
    How to edit the max sending size for MMS in Android

    Then install your modified Mms.apk using adb:
    adb remount
    adb push Mms.apk system/app
    adb reboot
    Attached Files Attached Files

  6. #16
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    Hi, sorry it took so long to get round to replying, your trick worked a treat thanks. O2 confirmed their default size was 300kb, and your instructions worked also so thanks again. For anyone else reading, don't spend hours modifying your APN's, download handcent, and then set the message size to 300KB and try that first.

  7. #17
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    glad to hear that worked for you! best of luck...
    Radio: 20100203_2 (EPE54B)
    Recovery: RA-nexus-v1.7.0 CM Version
    Rom: CyanogenMod v5.0.6
    Kernel: Pershoot's 2.6.33.3 OC/UV/BTN
    /AUD/RAM/VFPv3 (042610)
    OC mgmt: SetCPU 1.51a
    Theme: none right now...

  8. #18
    Android Lurker ceramista's Avatar
    Join Date
    Jan 2011
    Location
    Lisbon, Portugal, Portugal
    Posts
    1
    Quote Originally Posted by ceramista View Post
    I also canīt get MMS to work for me here in Portugal.
    Everything else works fine.


    Finally ALSO got MMS to work with Handcent. Thanks for the tip.

  9. #19
    Member ithc42's Avatar
    Join Date
    Apr 2010
    Posts
    48
    Did you ever get this issue resolved? I am not able to receive mms but apparently can get some to go through. Have no idea what to try. All settings are in accordance with the manual. Would greatly appreciate it if you have a solution and would share it.

Page 2 of 2 FirstFirst 12

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. When will the Behold get Android 2.2?
    By TMODroids User in forum Samsung Behold 2
    Replies: 1
    Last Post: 03-14-2011, 09:18 PM

Search tags for this page

google nexus 1 settings o2

,

o2 wap and mms not working

Click on a term to search our sites for related topics.
Android Forum