MMS Not working on O2 in uk

This is a discussion on MMS Not working on O2 in uk within the Nexus One Tech Issues / Bug Reports forums, part of the Nexus One category; Hi I've tried every permutation of APN config settings listed on just about every forum on the web, but MMS will still not work for ...

Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: MMS Not working on O2 in uk

  1. #1
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29

    MMS Not working on O2 in uk

    Hi

    I've tried every permutation of APN config settings listed on just about every forum on the web, but MMS will still not work for me on the nexus for my pay monthly O2 SIM. Has anyone got a fix or also had this issue? I've tried O2 support but to no avail (several times).

    cheers

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    well, since you've tried every permutation of APN config, this may be of no help and perhaps you've already read this:
    Google Nexus One - o2 Settings for 3G network access and MMS | The world according to pglewis
    Apparently, there are different APN and username settings for contract and pay-as-you-go customers...
    http://www.google.co.uk/support/foru...5fd32318&hl=en

    I've really got no idea where to begin with this otherwise...are you rooted? if so, you could change your "Custom User-Agent" settings to spoof your phone as an iPhone on the O2 network...

  4. #3
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29

    MMS Not working on O2 in uk

    Hi, thanks for the link, that one is the best written one on the web but unfortunately i've tried it to no avail, along with a few others. My phone is not rooted. If the staff at O2 had a bit more skill then i'm sure it could be sorted fairly easily but they don't have any settings whatsoever for this phone.

  5. #4
    Senior Member tonybhoy's Avatar
    Join Date
    Mar 2010
    Posts
    981
    Quote Originally Posted by stamina_josh View Post
    Hi, thanks for the link, that one is the best written one on the web but unfortunately i've tried it to no avail, along with a few others. My phone is not rooted. If the staff at O2 had a bit more skill then i'm sure it could be sorted fairly easily but they don't have any settings whatsoever for this phone.
    click the link and scrool down you can call or email thats what i used for orange uk
    HTC - About HTC - Contact Us by Phone

  6. #5
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    Thanks I will give it a go

  7. #6
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    I emailed HTC and they never got back - what poor service eh !

  8. #7
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    Do your web APN settings work ok (can you browse the inet with wireless off)?

  9. #8
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    Hi, yes the internet works and normal SMS messages work also, but not picture text messaging. It's really strange. ONLY picture messaging doesn't work, neither sending or receiving, it's really annoying I've tried virtually everything.

  10. #9
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    I'm sure you've already been down this path, but I'd thought Id throw it out there in case you hadn't:
    O2 Mobile Phone Settings

    Also, have you tried using the Milestone/Hero settings? Read here:
    Android Forums - View Single Post - 02 MMS/WAP settings for Hero

    In that post he mentions a modified apk for the N1...It's here:
    Android Forums

    Finally, every time you edit, remove, or reset you APN settings you've rebooted the phone, right? If not, I would strongly encourage you to do so. In fact, instead of editing them, I'd completely remove it/them, reboot, then replace with a new APN(s) entry.

    Try this on for size...first delete your current mms APN entry and reboot the phone. Then try these settings:
    Name= "o2 UK MMS PAYG" (or whatever you want...)
    APN= "payandgo.o2.co.uk"
    Proxy= <Not set> or **leave blank**
    Port= <Not set> or **leave blank**
    Username= "vertigo"
    Password="password"
    Server= <Not set> or **leave blank**
    MMSC= "http://mmsc.mms.o2.co.uk"
    MMS proxy= "193.113.200.195"
    MMS port= "8080"
    MCC= "234"
    MNC= "10"
    Authentication type= <Not set> or **leave blank**
    APN type= <Not set> or **leave blank**

  11. #10
    Junior Member stamina_josh's Avatar
    Join Date
    Feb 2010
    Posts
    29
    Hi, thanks for taking the time to provide the detail and try to help. Unfortunately the settings didn't work. Yes I am rebooting each time, HTC cust service have not been able to resolve this either. Although O2 customer service are friendly and helpful you get the whole Manucunian thing going on, needless to say, problem not resolved. It's really weird as I get a good 3G and web connection but just can't send MMS.

Page 1 of 2 12 LastLast

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. When will the Behold get Android 2.2?
    By TMODroids User in forum Samsung Behold 2
    Replies: 1
    Last Post: 03-14-2011, 09:18 PM

Search tags for this page

google nexus 1 settings o2

,

o2 wap and mms not working

Click on a term to search our sites for related topics.
Android Forum