pics & movies keep disappear from my SD card

This is a discussion on pics & movies keep disappear from my SD card within the Nexus One Tech Issues / Bug Reports forums, part of the Nexus One category; I have had my nexus one for now about one month, and I've been running with android 2.2 (FRF50) until yesterday when I upgraded to ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: pics & movies keep disappear from my SD card

  1. #1
    Junior Member Cappella1978's Avatar
    Join Date
    Jul 2010
    Posts
    2

    pics & movies keep disappear from my SD card

    I have had my nexus one for now about one month, and I've been running with android 2.2 (FRF50) until yesterday when I upgraded to FRF91.

    about one week after I got my phone, I noticed about 80% of the pictures and movies I had put on my sd card disappeared. I thought my SD card could be the problem, so I tested it, all was fine and I put back my pics & movies on it (about 1000 files, all pics & movies I had taken with my previous nokia N95, for which I have a backup fortunately). a while after I noticed some movies & pictures had disappeared again! My sd card which was almost full now showed 30% free space! (a sandisk 16GB class 2 card).

    Just to be safe last week I bought a new sd card (kingston 16GB class 10), and copied files on it to almost fill it (95%), this morning same thing happens again (I had upgraded to FRF91 yesterday but files were still there after). Now... I also lost almost all pics & movies taken with my nexus one for which I have no backup! I took out my SD card and put it on my computer and run easyus recovery, and all the missing files were found and marked as DELETED!! Not a FAT corruption or anything, just plainly deleted... how is that possible?

    No other files than pics & videos were deleted, no mp3 or other files.

    I didn't do any usb transfer for 3 days, so I can't have done a mistake.

    Has anyone experienced this?

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Senior Member N1David's Avatar
    Join Date
    Feb 2010
    Posts
    866
    This is the second posting I have seen about 16 GIG SD cards loosing files. Maybe something in the size of the SD card that the Nexus One doesn't like?

  4. #3
    Android Addict alphawave7's Avatar
    Join Date
    Jan 2011
    Posts
    609
    Thanked
    62 times
    Quote Originally Posted by N1David View Post
    This is the second posting I have seen about 16 GIG SD cards loosing files. Maybe something in the size of the SD card that the Nexus One doesn't like?
    I hope not! My sd is 16G!

  5. #4
    Junior Member Cappella1978's Avatar
    Join Date
    Jul 2010
    Posts
    2
    I don't think it has to do with the SD size... but I have suspicions on the Gallery Application, had a lot of trouble with it. On top of it, I bought xyplayer to play wmv, avi ... and none of those files ever disappeared, only mp4 and jpg.

    If I transfer new files to my sd card, often the gallery application won't see them. I had to delete all thumbnails in the cache (not a one click operation unfortunately) to force it to recheck pictures, another time, it got corrupted somehow. I store a lot of comic books scans, and I noticed my picture folder was showing comic book thumbnails!! when I clicked on the picture, it would show the comic, however if I went to the same directory/file with ASTRO file manager, it would open the picture correctly, once again, I had to manually delete all thumnails & cache to force it to rescan (and no file were corrupted). Happened again today, after recovering my files, I put them on the sd card and... gallery don't see them!

    Also had the gallery hang with 100% cpu usage a couple of times... one time it almost totally drained my battery in just a few hours, another time my phone got pretty hot in my pocket I was wondering why... gallery stuck at 100% cpu usage (hadn't even used it that day!)

    Maybe the gallery goes crazy if you store too many media files (thousands)? Also is there another way to force-refresh the gallery without having to delete /Android/data/com.cooliris.media/cache and /DCIM/.thumbnails... I also don't understand why there are 2 caches? if I delete the .thumbnails alone gallery still show old cached data

  6. #5
    Android Addict alphawave7's Avatar
    Join Date
    Jan 2011
    Posts
    609
    Thanked
    62 times
    Quote Originally Posted by Cappella1978 View Post
    I don't think it has to do with the SD size... but I have suspicions on the Gallery Application, had a lot of trouble with it. On top of it, I bought xyplayer to play wmv, avi ... and none of those files ever disappeared, only mp4 and jpg.

    If I transfer new files to my sd card, often the gallery application won't see them. I had to delete all thumbnails in the cache (not a one click operation unfortunately) to force it to recheck pictures, another time, it got corrupted somehow. I store a lot of comic books scans, and I noticed my picture folder was showing comic book thumbnails!! when I clicked on the picture, it would show the comic, however if I went to the same directory/file with ASTRO file manager, it would open the picture correctly, once again, I had to manually delete all thumnails & cache to force it to rescan (and no file were corrupted). Happened again today, after recovering my files, I put them on the sd card and... gallery don't see them!

    Also had the gallery hang with 100% cpu usage a couple of times... one time it almost totally drained my battery in just a few hours, another time my phone got pretty hot in my pocket I was wondering why... gallery stuck at 100% cpu usage (hadn't even used it that day!)

    Maybe the gallery goes crazy if you store too many media files (thousands)? Also is there another way to force-refresh the gallery without having to delete /Android/data/com.cooliris.media/cache and /DCIM/.thumbnails... I also don't understand why there are 2 caches? if I delete the .thumbnails alone gallery still show old cached data
    Another user had posted similar results (but not actual data loss) when loading a LOT of content...the gallery app has to first find the new data, then index it (I assume the thumbnails get priority) and then build the full resolution pics. The whole process takes time (which is somewhat surprising since lesser devices with far less processing power can do it quicker) but it was seen as best to let the process complete itself rather than try to circumvent it (by say, deleting thumbs,etc.). You could try going to settings->apps->all apps and locate Gallery, and select clear data, which I hope gives you a fresh start. Please back up everything first, however! Let us know how it goes...

  7. #6
    Junior Member Jesse_Krebs's Avatar
    Join Date
    Jul 2010
    Posts
    3
    Same issue here. One morning while playing music on my N1 through headphones I started hearing the music skip as if it was doing a song intro. demo you could hear the first few seconds of each song when I looked at my player(doubletwist) I saw the player skipping through the tracks. When I attempted to view pics right after I noticed my Gallery was stuck at "loading new pictures" I backed out of gallery a few times nothing kept reading " no items in your collection" used my file browser(astro) and was able to see all my downloaded files including pictures,data,cache's but no "CAMERA" pictures or "VIDEO" the folders were empty.
    The card was a SanDisk 8GB Class2.

    I am currently using a SanDisk 1GB card and guess what!?
    It already gave me a similar symptom but this time I didnt play with it a whole lot and quickly plugged into my PC using a card reader and was able to back up all my pics. So to be clear this second time around the card on my phone started giving me a "no items in collection" when in Gallery but when it was plugged into my PC I was able to see and retrieve those items. Definitively something to do with the "Gallery" I would assume.

    Any advice and/or help would be greatly appreciated.
    Thanks in advance.

  8. #7
    Senior Member rioja's Avatar
    Join Date
    Mar 2010
    Posts
    741
    I have had to replace 2 SD cards in my Nexus One already because they've been corrupted or gone bad. Up until then, I never had to replace an SD in any phone I've ever owned.

    Maybe it's just bad luck, but I don't believe it. I also don't think it's a coincidence that loading the Gallery can be very slow when reading from the SD, whether the caches are built or not. I find the gallery slower in 2.2 than it was in 2.1.

    The tendency for my cards to corrupt is one of the reasons I've stayed away from apps2sd in Froyo until I really need it.

  9. #8
    Senior Member N1David's Avatar
    Join Date
    Feb 2010
    Posts
    866
    That is a definite bummer about your needing to replace two SD cards.
    Brings up a good thought though - if your SD card goes bad and you have apps installed on it; what happens to the phone? I am not familiar with the operating system on the Nexus Ones, but is there left over registry entries for the missing apps? Does the operating system even contain a registry?

    Now for the Gallery app, it is definitely buggy and slower in Froyo 2.2. Pictures I save from Handcent are not viewable until I power cycle the phone off and on. Sometimes I can get the gallery to "see" saved pictures from Handcent if I plug the Nexus One into my computer and enable the computer to view the SD card. That sometimes causes the Gallery to refresh & sometimes it doesn't.
    Also, MP4 videos were playable on my Nexus One before Froyo but after the upgrade they will not play anymore. I have to re-convert the MP4 video to a MP4 video to get it to play now.

  10. #9
    Junior Member Giles's Avatar
    Join Date
    May 2010
    Posts
    4
    I too have been having a problem last few days with my sd card. It started bugging out when i tried to play a movie i had on my sd card, the phone would lock up and get warm and i would have to reboot.
    This happened for a few days, well today any pictures i had saved to my sd card and movies have disappeared, but apps i have installed on sd are still there working.
    When i go into the gallery it says the sd card is not detected and might be unmounted, this is while i can still use apps that are saved to the sd.
    Well i try to format the card and now i get the message the card is not recognizable any more. Then it tells me the card has errors and i should format but it doesn't seem to do anything.
    This was a new 16g Scandisk card bought about 2 months ago. So i guess im going to go buy another but get the feeling the same thing might happened again.

    Seems like im not the only one have problems with sd card since froyo?

    Any suggestions?

    thanks

  11. #10
    Senior Member N1David's Avatar
    Join Date
    Feb 2010
    Posts
    866
    There seems to be a lot of problems with the 16 Gig card. I have seen so many postings here about that. If I ever do get a bigger card, 8 GIG would be the biggest I'd go to.

Page 1 of 3 123 LastLast

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

android files disappearing from sd card

,

downloaded files disappear android

,

files disappearing in my android phone

,

files dissapeared andriod

,

movies disappear from android

,

movies disappeared from sd card

,
movies dissapear from sd card on droid
,

my movies dissapeared from sd card

,
my saving pictures disappered after few days in s4 mobile
,
photos disappear from sd card
,

pics and videos dissapeared on sdcard android

,
the files put in microsd disappear
,

video files disappear android

,
videos disappear from sd card
,
why my image suddenly dissapear from my sd card
Click on a term to search our sites for related topics.
Android Forum