I have a nexus one (unlocked, t-mobile version, but running on AT&T), and the current build of froyo on it is FRF33B (a non-public beta build given out to flash developers). It says it's up to date when I try checking for system updates. I tried downloading build FRF50 from online and doing a manual update, but I got the signed package verification error.

I'd like to be able to update... the build I have is a bit buggy and I thought it was supposed to update itself when it was taken out of beta.