Weird power button problem

This is a discussion on Weird power button problem within the Nexus One Tech Issues / Bug Reports forums, part of the Nexus One category; Hi guys, Ran into this weird problem a couple of times now (4+) and wanted to see if anybody had seen it before. I'm on ...

Results 1 to 9 of 9

Thread: Weird power button problem

  1. #1
    Junior Member SM05's Avatar
    Join Date
    Jul 2010
    Posts
    8

    Question Weird power button problem

    Hi guys,

    Ran into this weird problem a couple of times now (4+) and wanted to see if anybody had seen it before. I'm on unrooted 2.2 and this is my 2nd phone, which is ironically a swap for a failed power button.

    So, what happens is that after several of days of working fine the phone's power button doesn't lock/unlock it correctly anymore. When phone is asleep, I hit power button and it shows the standard unlock screen. The unlock button is basically unresponsive. Trying to lock it via power button at that point doesn't put the phone to sleep but rather dims the screen a bit instead. If I press power button again it just goes through the same cycle again.

    A few times when that had happen before I was able to just let the lock screen timeout and go to sleep and then after a few tries it'd work fine again. Last couple of times nothing helped. So, I had to do a battery pull.

    Any ideas on what's going, and whether that's likely a software or yet another hardware issue?

    Thanks in advance.

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Junior Member hazzazi's Avatar
    Join Date
    May 2010
    Posts
    14
    that happened to me before when i was on 2.1, but after the upgrade to 2.2 it fixed itself... i'm not sure what caused the problem or why it has happened, but good luck.

    p.s. also sometimes when that used to happen, i couldn't even answer the phone when someone calls (it wont allow me to side the thing to answer).

    i hope someone with more knowledge could help you.

  4. #3
    Senior Member coldfusionb's Avatar
    Join Date
    May 2010
    Posts
    215
    Have you tried a factory reset to see if that helps?
    One Nexus To Rule Them All!

  5. #4
    Senior Member FlyingsCool's Avatar
    Join Date
    Feb 2010
    Posts
    369
    I think this has to do with an app you have installed that is locking up. Have you installed any apps or upgraded any apps recently that you are aware of?

    Basically, the phone turns on, but is unresponsive because it is locked in a loop somewhere.

    My only choice when this has happened was to take the battery out. Haven't had the problem happen to me for a while. I don't think this is a power button problem. But that is only my opinion.

  6. #5
    Member arhidia's Avatar
    Join Date
    Apr 2010
    Posts
    62
    I've had the same problem happen to me this past week. I only did a battery pull once so far. Two times the unlock screen was unresponsive, but somehow worked after pushing the power button several times.

  7. #6
    Junior Member SM05's Avatar
    Join Date
    Jul 2010
    Posts
    8
    Thanks for all of the replies.

    I've done a factory reset after getting 2.2 installed on my phone. I was having terrible battery performance issues and did a full reset, which had helped a lot. I might give another reset a try.

    If this is some badly behaving app, I'm just wondering if there is any way to determine which one that is by checking some log or performance stats? I update apps as updates become available so it's hard for me to identify the offending update. The only new / recently installed app I can think of that runs all the time is PingChat. I used to use eBuddy but switched to PingChat. Come to think of it, these lock ups started "sort of" around the same time frame. Hmm... Anybody else using PingChat too?

    Thanks.

  8. #7
    Member arhidia's Avatar
    Join Date
    Apr 2010
    Posts
    62
    I also use PingChat, but I downloaded that app in mid August. I only had the button problem happen in this last week.

  9. #8
    Junior Member jbilbo's Avatar
    Join Date
    Oct 2010
    Posts
    1
    I've also the same problem. Any updates on this topic?

  10. #9
    Junior Member shadowman2010's Avatar
    Join Date
    Feb 2011
    Posts
    1
    Problem fixed....form me....

    I have had the power button problem for about one month…I did all provided solutions but nothing fixes the problem ….
    Finally when I installed Screen Off And Lock V1.7 from Android Market and use it for one day the Power Button came back to life !!!!
    Give it at try.

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

power button on nexus 4 problem

Click on a term to search our sites for related topics.
Android Forum