So I'm using the stock e-mail on my N1. When I send e-mails, the custom signature shows up at the bottom of my e-mail, which is perfect, but when I reply to an e-mail there is no signature. I don't see a setting on how to change it so that the signature always goes out with my e-mail. Can anyone help?

And if anyone is using a better e-mail app, please recommend one.