Chain of events:
1. Nexus One purchased via Google prior to closing their on line store. Love it.
2. Running out of room for more apps. Unlock Bootloader and Root.
3. Miui for a while then to CM7 nightly. Great.
4. Partition to Ext3. Then with Link2SD and S2E. All goes well though a little slow.
5. Try to optimize and now problems! All apps in SD are gone, many gone from phone, unit now appears to have lost root, cannot download apps for Google Play, S-ON in Bootloader Screen, and more. Phone still works but VERY slow reboot.
6. Tried to install new recovery. Gets to 4 color X and unlocked padlock and hangs.
7.Tried to root using Doomlord. Will not.

At this point I am lost for other options. My skills with a PC and command lines are close to zero (a friend helped with the root) as I use a MAC.

Can I just reset all to factory (is that correct) to get all the linked files outta there (from the Link2SD links!?). I think that is the problem.

Any ideas/suggestions are appreciated. Can I put it back to factory and root again?