Well here's my long story...
i was running QND MIUI for about 2 months, thought of checking ICS,
so i took nandroid and installed MIUI ICS (non blackrose version).
installation went fine and it booted up good. but i found it to be laggy and
so decided to restore my previous rom. so i switched off.(the problem started nw)
when i pressed on the power button it didnt boot. i tried pressing as hard as possible
but nothing happened.

Battery Swap
so i tried swapping batteries with my brother's nexus one. his phone booted but mine didn't
(so my battery is fine)

Battery Trick
i tried the battery trick, again my brother's phone booted but mine didnt
( so my power button should be fine)

i connect my phone to pc via usb charger. the orange led glows but its not detected by system.
when i charge using wall charger, again orange led glows and after some time it turns green
( so battery stats is read correctly)

My nexus is SLCD variant with unlocked bootloader
so is my nexus dead ? what could be the problem? is there any solution to bring it alive? or should i hand it over to htc service center ?
EDIT : have linked two videos of how i do battery trick
1- working in my bro's phone - [ame=http://www.youtube.com/watch?v=2O5adV-jj64]nexus one battery trick1 - YouTube[/ame]
2- not working in mine - [ame=http://www.youtube.com/watch?v=JCyPIyGorFk]nexus one battery trick 2 - YouTube[/ame]