Hey everyone, as I got my Nexus One today for some reason it wouldn't connect to my 3G network or send MMS, so I noticed the APN settings weren't setup for the Nexus. After a quick call to Nexus Support they told me the correct settings and everything works perfectly!

MAKE SURE YOU SETUP TWO DIFFERENT APNS, ONE FOR DATA AND ONE FOR MMS!!!

Here are the settings for Data

Name: Rogers
APN: internet.com
Username: wapuser1
Password: wap
MCC: 302
MNC: 72 (If that doesn't work try 720, its already filled in, leave it at what it is)

Leave the rest blank. Now you Data should be working

Here are the settings Multimedia Messaging

Name: Rogers MMS
APN: media.com
Username: media
Password: mda01
Server: 172.25.0.107
MMSC :http://mms.gprs.rogers.com
MMS Proxy: 10.128.1.69
MMS Port: 80
MCC: 302
MNC: 72 (If that doesn't work try 720, its already filled in, leave it at what it is)
APN Type: mms

Leave the rest blank. Now MMS should be working!