Quote Originally Posted by greg View Post

Make sure data roaming is turned off in the settings. It may be worth getting a sim card from the country you are going to.
I agree with you.