Singtel MMS Settings

This is a discussion on Singtel MMS Settings within the Nexus One forums, part of the Google Phones category; With the default settings, I'm unable to send out MMS. I can surf the web and stuffs, MMS just cant go thru. I've done this ...

Results 1 to 8 of 8

Thread: Singtel MMS Settings

  1. #1
    Junior Member overide's Avatar
    Join Date
    Apr 2010
    Posts
    5

    Singtel MMS Settings

    With the default settings, I'm unable to send out MMS. I can surf the web and stuffs, MMS just cant go thru.

    I've done this and it still does not work:

    - name: SingTel Internet
    - APN: internet
    - username: 65IDEAS (or blank)
    - password: IDEAS (or blank)


    Called up HTC and their tech wasted 30mins of my time. Said he will mail me the needed config.
    Called up Singtel and since the phone was not on their list, their tech was not able to provide any help.

    now what......


  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Android Addict alphawave7's Avatar
    Join Date
    Jan 2011
    Posts
    609
    Thanked
    62 times
    Quote Originally Posted by overide View Post
    With the default settings, I'm unable to send out MMS. I can surf the web and stuffs, MMS just cant go thru.

    I've done this and it still does not work:

    - name: SingTel Internet
    - APN: internet
    - username: 65IDEAS (or blank)
    - password: IDEAS (or blank)


    Called up HTC and their tech wasted 30mins of my time. Said he will mail me the needed config.
    Called up Singtel and since the phone was not on their list, their tech was not able to provide any help.

    now what......

    Are you already a Singtel customer? If so, call them up and demand the service you are paying for! It doesn't matter the phone is not 'in their list'..you are seeking proper setting to do MMS on *any* phone!

  4. #3
    Junior Member overide's Avatar
    Join Date
    Apr 2010
    Posts
    5
    Yes I'm already an existing singtel customer. Did i mention that HTC tech asked me to Restore my device to factory defaults?? pfft.

    I'll call up singtel again tomorrow.

    HTC sent me an email asking me to ensure my settings are as follows.

    Name - IDEAS MMS
    APN - e-ideas
    Proxy - 165.21.42.84
    Port - 8080
    Username - 65IDEAS
    Password - ideas
    Server - <Not set>
    MMSC - http://mms.singtel.com:10021/mmsc
    MMS proxy - 165.21.42.84
    MMS port - 8080
    MMC - 525
    MNC - 01
    Authentication type - <Not set>
    APN type - mms


    On my end this is what i see.

    Inside, Settings> Wireless & Network> Mobile Networks> Access Point Names

    I see 2 APNs

    1st APN -> IDEAS. There is a Green Light selected on this option
    Name: IDEAS
    APN: e-ideas

    Everything else is blank


    2nd APN -> IDEAS MMS

    Name - IDEAS MMS
    APN - e-ideas
    Proxy - 165.21.42.84
    Port - 8080
    Username - 65IDEAS
    Password - ideas
    Server - *
    MMSC - http://mms.singtel.com:10021/mmsc
    MMS proxy - 165.21.42.84
    MMS port - 8080
    MMC - 525
    MNC - 01
    Authentication type - <Not set>
    APN type - mms

    With the above settings I am able to surf the web go to the Android Market and install stuffs everything is ok EXCEPT sending out MMS


    The minute I edit the First APN to have the same settings as the second, I'm disconnected to the 3G network. I cannot surf the web at all.

  5. #4
    Android Addict alphawave7's Avatar
    Join Date
    Jan 2011
    Posts
    609
    Thanked
    62 times
    Quote Originally Posted by overide View Post
    Yes I'm already an existing singtel customer. Did i mention that HTC tech asked me to Restore my device to factory defaults?? pfft.

    I'll call up singtel again tomorrow.

    HTC sent me an email asking me to ensure my settings are as follows.

    Name - IDEAS MMS
    APN - e-ideas
    Proxy - 165.21.42.84
    Port - 8080
    Username - 65IDEAS
    Password - ideas
    Server - <Not set>
    MMSC - http://mms.singtel.com:10021/mmsc
    MMS proxy - 165.21.42.84
    MMS port - 8080
    MMC - 525
    MNC - 01
    Authentication type - <Not set>
    APN type - mms


    On my end this is what i see.

    Inside, Settings> Wireless & Network> Mobile Networks> Access Point Names

    I see 2 APNs

    1st APN -> IDEAS. There is a Green Light selected on this option
    Name: IDEAS
    APN: e-ideas

    Everything else is blank


    2nd APN -> IDEAS MMS

    Name - IDEAS MMS
    APN - e-ideas
    Proxy - 165.21.42.84
    Port - 8080
    Username - 65IDEAS
    Password - ideas
    Server - *
    MMSC - http://mms.singtel.com:10021/mmsc
    MMS proxy - 165.21.42.84
    MMS port - 8080
    MMC - 525
    MNC - 01
    Authentication type - <Not set>
    APN type - mms

    With the above settings I am able to surf the web go to the Android Market and install stuffs everything is ok EXCEPT sending out MMS


    The minute I edit the First APN to have the same settings as the second, I'm disconnected to the 3G network. I cannot surf the web at all.

    Which makes sense...the first APN is your browsing settings, the second APN is your MMS settings. Double-check those second APN settings, then reboot the phone. If it still cannot MMS after that, call them back and tell them. They may have alternate settings/servers, that they need to dig for...

  6. #5
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    First off, be very certain that you are entering the APN information exactly how it was typed; it is case-sensitive. Maybe you could try these SingTel settings (These are Cyanogen's settings I pulled from here , a semi-maintained list of known working APN's):

    First APN entry (network):

    Name: IDEAS
    APN: e-ideas
    Proxy: <not set> *leave blank*
    Port: <not set> *leave blank*
    Username: *
    Password: *
    Server: *
    MMSC: <not set> *leave blank*
    MMS proxy: <not set> *leave blank*
    MMS port: <not set> *leave blank*
    MCC: 525
    MNC: 01
    Authentication type: <not set> *leave blank*
    APN type: <not set> *leave blank*

    Second APN entry (MMS):
    Name: IDEAS MMS
    APN: e-ideas
    Proxy: <not set> *leave blank*
    Port: <not set> *leave blank*
    Username: 65IDEAS
    Password: 65
    Server: <not set> *leave blank*
    MMSC: http://mms.singtel.com:10021/mmsc
    MMS proxy: 165.21.42.84
    MMS port: 8080
    MCC: 525
    MNC: 01
    Authentication type: <not set> *leave blank*
    APN type: mms

    Naturally, reboot after entering.

    But wait..there's more!

    Here's another thing you may not be aware of...and this is going to get a little technical...

    As with most wireless carriers, SingTel limits your MMS size to 300 kilobytes. If you're trying to send and image that is larger than that, the messaging app is supposed to alert you and offer to reduce the size for you. However, there is a known issue in the stock messaging app that it doesn't resize pictures until they reach over 1024kb and/or greater than 2592x1944 pixels. Even if it does reduce the size, it may not reduce them enough...here's proof of those values:

    <technical mumbo-jumbo>
    In this image, I'm showing you a portion of the actual mms_config.xml from the stock app opened in a hex editor:



    What we see there is that the stock app sets the maximum MMS message size limit at 1048576 bytes which is equal to 1024kb. The max picture width/height size are 2592x1944. And finally, the user-agent string is "Nexusone" which some have is not supported by all carriers yet.
    </technical mumbo-jumbo>

    This is a big problem because images between 300 and 1024kb are not going to trigger the resize option! The bottom line is that the stock messaging app maximum values are set WAY too high for most carriers with the 300kb limit and the carrier will not deliver the over-sized message. This leaves you with only a few options.

    1. Take your pictures at no greater than 1280x768 if you plan to send them via MMS. Test this by taking a picture with the smallest image setting and then send an MMS with that image attached...if your APN setting are correct, it should be delivered. That is unless if your carrier has an issue with the user-agent part.

    2. Use Handcent or ChompSMS and change the settings in that app to reflect the 300k maximum. These apps are much more robust than the stock messaging app and should appropriately resize the image for you. If that doesn't work, some users have reported that changing the "Custom User-Agent" setting to spoof your phone on your carrier's network as something other than "Nexusone" has been successful...I'd try "Default Android" or "iPhone (3.0)".

    3. Lastly, If your phone is rooted, you can push a modified Mms.apk on to your phone and overwrite the stock version. These modified versions usually change the user-agent string and reduce the maximum message size to 300k and maximum image size to accommodate the 300k limit. These can acquired at the XDA, Modaco, and Cyanogen forums if you search.

    I hope all this information helps you and anyone else having problems sending MMS messages! Good luck...

  7. #6
    Junior Member overide's Avatar
    Join Date
    Apr 2010
    Posts
    5
    kc.rkitek,

    You were spot on.

    I checked the file size and indeed the default settings of the imagine was huge. Even after the "resizing" when i attached an image to the sms.

    I scaled down the image size, cropped it smaller and sent out a 53kb file with my default APN setting.

    It's quite misleading, cos the N1 does tell you that it's "resizing" and yet it still doesn't go thru.


    Life Saver, now I can sleep in peace... lol


    thanx!

  8. #7
    Senior Member kc.rkitek's Avatar
    Join Date
    Jan 2010
    Posts
    291
    Good news! Did you end up using a different APN than those I listed above? If your settings are different, would you mind adding a comment to this page:
    APNlist - cyanogenmod - page to maintain an accurate working list of APN's for cyanogen (and other?) builds. - Project Hosting on Google Code
    It would really go a long way to help rom developers and other users in the future.
    Glad it's all working for you...best of luck!!

  9. #8
    Junior Member overide's Avatar
    Join Date
    Apr 2010
    Posts
    5
    oh no. The APNs that I'm using were exactly like those that you listed.

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

165.21.42.84
,
how to mms on iphone 4 in singtel
,
http mms singtel com 10021 mmsc
,
mms setting for singtel
,
mms settings fir singtel
,
mms singtel password ask
,
mms.singtel.com:10021/mmsc
,
samsung gti9152 mms settings singtel
,
singtel mms apn
,
singtel mms setting
,

singtel mms settings

,

singtel mms settings android

,
singtel mms settings for android
,
singtel mobile mms setup
,
unable to receive mms on singtel
Click on a term to search our sites for related topics.
Android Forum