Why is Android WiFi still so flaky ?

This is a discussion on Why is Android WiFi still so flaky ? within the Nexus One forums, part of the Google Phones category; My friend I have tried this app. It will not connect to password protected unless you know the password. Just try it...

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Why is Android WiFi still so flaky ?

  1. #11
    Android Lurker Lionsson's Avatar
    Join Date
    Jan 2011
    Posts
    0
    My friend I have tried this app. It will not connect to password protected unless you know the password. Just try it

  2. #12
    Android Lurker Lionsson's Avatar
    Join Date
    Jan 2011
    Posts
    0
    WeFi can be setup to connect only to known connection and avoid it from connecting to every open WiFi. You need to try it, how else are you doing to find a solution.

    and like I said I can alway setup a tasker profile that will solve your problem, but I'll takes more effort than what your putting in right now.

  3. #13
    Android Lurker Lionsson's Avatar
    Join Date
    Jan 2011
    Posts
    0
    Let me know what you decide.

  4. #14
    Senior Member dd4005's Avatar
    Join Date
    Apr 2010
    Posts
    390
    Cool, I'll give it a try. Normally I'd just try an app, but after reading the comments about what it can do to your existing wifi config, and various other comments, I decided I'd just hold off.

    I don't know what a tasker profile is, but it sounds like something that might need the phone to be rooted. Is that true?

    Anyway, I'm gonna try the wefi now. It'll take a few days to get a good long test result. It's too easy to jump to a conclusion on too short a test.

    Update: Nice looking app. It doesn't help the initial connection after turning on airplane mode and then enabling wifi. The first 2 or 3 connect attempts fail and then success. I hoped wefi might automate that but if anything it appears to make things worse. Oh well, maybe it will at least hold onto the connection once it's obtained.

  5. #15
    Member DThor's Avatar
    Join Date
    Jul 2010
    Posts
    58
    Why are you enabling Airplane mode? Did you try not doing that as I suggested?

    Also, wefi might 'sort of' handle the issue, so would Tasker, but really, these are both a hack approach that will end up burning up more battery power. The issue is still there, all they're doing is kicking it in the ass on a regular basis. As I mentioned, there's dozens of threads out there on the net with people discussing 'my android disconnects wifi'. I would recommend finding comments from people running specifically your router. Mine used to do it a *lot*, but since upgrading the firmware to the latest, it happens at most once a week.


    DT

  6. #16
    Senior Member dd4005's Avatar
    Join Date
    Apr 2010
    Posts
    390
    Quote Originally Posted by DThor View Post
    Why are you enabling Airplane mode? Did you try not doing that as I suggested?

    Also, wefi might 'sort of' handle the issue, so would Tasker, but really, these are both a hack approach that will end up burning up more battery power. The issue is still there, all they're doing is kicking it in the ass on a regular basis. As I mentioned, there's dozens of threads out there on the net with people discussing 'my android disconnects wifi'. I would recommend finding comments from people running specifically your router. Mine used to do it a *lot*, but since upgrading the firmware to the latest, it happens at most once a week.
    DT
    Just uninstalled WeFi after waking up and seeing it tell me there are no visible wireless networks. :rofl3::rofl3:

    When I went into the wifi settings I see my router name there and it's set to "Disabled". It offers me a Connect button, which I press, and it's connected again. WeFi wasn't able to enable to see my router because overnight it had somehow been disabled in the phone. No freaking idea how that happens. When I left it to go to sleep, it was enabled, ebuddy was online, wefi was on. When I wake up, the connection is disabled. I don't think any app can get around that (fundamental flaw in Android).

    I need Airplane mode on because where my dock is located (between my speakers and Cisco IP phone) I get that familiar GPS speaker interference every now and then (far too often for my liking). In airplane mode that doesn't happen. I don't want to locate the dock far enough away from the speakers that it doesn't happen, because then it's half way across the room in a place I don't want it to be.

    I don't need a firmware update (not that there is one higher than what I've got) as my router works fine for ALL devices connected to it except for android phones.

  7. #17
    Senior Member dd4005's Avatar
    Join Date
    Apr 2010
    Posts
    390
    Maybe it's because I'm in Airplane mode that I'm having these problems, because when you do go into airplane mode it disables wifi by default. I always have to re-enable wifi after going into airplane mode. Doing that in itself isn't such a bad thing, but perhaps the re-enabling has a limited lifespan. Perhaps it's treated as a short-term re-enable and after some time Android thinks "oh, I'm supposed to be in airplane mode, I better disable that wifi there". Or something like that.

    Off to find another way of disabling the phone side of things. I guess taking the SIM card out will do the job. Maybe I can disable the SIM card rather than removing it.

    edit: Failed to find another way of disabling the phone other than airplane mode. As a test, I'm leaving airplane mode off and seeing if the wifi will drop or if it can hold onto the connection now. If it drops anyway, then I can stop worrying about it being airplane mode as the cause.

    edit2: so much for airplane mode being the culprit. With airplane mode not set, *still* the wifi drops after an hour or two and when I look in the wifi settings I see my router listed there as present with an "excellent" signal but in a state of "Disabled". One click "connect" and it's going again but no known reason how it got to be disabled.

    I give up, it's bloody hopeless. I can't recommend Android phones anymore, not if someone wants to use wifi.

    I think my idea of waiting for a 7-10" android tablet is now off the table. I'm going to have to think about an iPad or a Windows 7 tablet instead. I never imagined I'd find myself saying that.

  8. #18
    Member DThor's Avatar
    Join Date
    Jul 2010
    Posts
    58
    Airplane mode means 'no networking ', which is why I suggested it way back at the start of the thread. It was a diagnostic suggestion which worked, unsurprisingly. Every phone with a radio causes reconnects attempts sounds near speakers. Why not try disabling your radio instead, which is what airplane mode does along with other protocols?

    DT

  9. #19
    Senior Member dd4005's Avatar
    Join Date
    Apr 2010
    Posts
    390
    Quote Originally Posted by DThor View Post
    leave airplane mode off for starters, see if that makes a difference
    Quote Originally Posted by dd4005 View Post
    With airplane mode not set, *still* the wifi drops after an hour or two and when I look in the wifi settings I see my router listed there as present with an "excellent" signal but in a state of "Disabled". One click "connect" and it's going again but no known reason how it got to be disabled.
    Quote Originally Posted by DThor View Post
    Airplane mode means 'no networking ', which is why I suggested it way back at the start of the thread. It was a diagnostic suggestion which worked, unsurprisingly.
    See above. It didn't work. Not sure why you think it did.

    I'm currently playing with the app inventor to see if I can write my own app to auto re-enable my wifi connection once every couple of seconds. That should fix whatever bug is causing it to become disabled. Hopefully the API gives me the power to do that.

  10. #20
    Android Jr Member Fury's Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    67
    Thanked
    8 times
    Twitter
    Nd1razor
    Im having similar problems, iv found this but am a bit hesitant to try:
    Fix My WiFi - Cyrket

Page 2 of 3 FirstFirst 123 LastLast

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

android cm11 m6 wifi turns on when asleep
,

android flaky wifi

,
android tablet flaky wireless connection
,
android wifi flaky
,
cm11 wifi sleep
,
flaky wifi android can not find wifi
,
flaky wifi in adnroid phones
,
nexus 7 flaky wifi
,
no wifi icon when there is no wifi android
,

why has my phone stop accepting my wifi signal

,
why is wifi so flakey
,
why is wifi so flakey?
,
why no wi fi icon on nexus5 phone
Click on a term to search our sites for related topics.
Android Forum