Can't upgrade from 2.2 - "assert failed"

This is a discussion on Can't upgrade from 2.2 - "assert failed" within the Nexus One forums, part of the Google Phones category; I am N1 newbie but not Android newbie - have been using rooted Droid Incredible as my "main" phone for several months. I just purchased ...

Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't upgrade from 2.2 - "assert failed"

  1. #1
    Junior Member JoeSchmoe007's Avatar
    Join Date
    May 2011
    Posts
    6

    Can't upgrade from 2.2 - "assert failed"

    I am N1 newbie but not Android newbie - have been using rooted Droid Incredible as my "main" phone for several months.

    I just purchased officially unlocked N1 that is currently activated on prepaid T-Mobile account in USA and in future it will be used on my vacation in Europe.
    Phone came with OS v. 2.2

    I successfully unlocked bootloader and flashed latest Amon RA recovery

    In this thread: http://forum.xda-developers.com/show...php?p=13947027 I was told that direct upgrade from 2.2 to 2.3.3 is possible (now I am not sure this is correct)

    When I tried to upgrade to 2.3.3 (downloaded from Google) I get this error:

    Installing update...
    assert failed: file_getprop("/system/build/prop", ro.build.fingerprintE:unknown command [")]
    file_gewtprop("/system/buil.prop", "ro.build.fingerprint") == "gE:unknown command [oogle/passion/passion/mahimahi:2.2.2/FRG83G/91102:user/release-keys"]

    E:Error in /sdcard/update.zip
    (Status 7)

    So I figured - let me try to upgrade to the previous version (2.2.2) - the same error.

    I googled for an hour and it seems that a lot of people have the same error message but there were just 2 possible solutions:

    1) Download and flash newer HBOOT (0.35.00017) - found here (post by David Goemans):

    http://phandroid.com/2011/02/24/manu...3-gingerbread/

    I did this and it didn't help - same error

    2) Install clockworkmod recovery 2.0.1.3 as mentioned here:

    [ FIXED! ] Can't flash FRF91, throws "assert failed... getprop("ro.build.date.utc")" - xda-developers

    I installed SU, installed ROM manager but the oldest CWM recovery available now is 2.5.1.1. I tried it and get the same error. Latest CWM recovery (3.0.0.5) produces the same error.

    Anyone can help?

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Android Lurker DudeRandom21's Avatar
    Join Date
    Aug 2011
    Posts
    0
    Ok well the upgrade to 2.3.3 is possible but you need a full ROM not just an update so I would get a full version of 2.3.3 (rooted or you will lose root) and then flash it. May I suggest getting a custom ROM like cm7.0.3 it is a modded version of 2.3.3 here is a list of custom ROMs you can chose from http://www.nexusoneforum.net/forum/n...roms-list.html and if you just want a rooted version of 2.3.3 then here you go [ROM] GRI40 Stock, Deodexed, rooted, busybox, battery %, TB alert 3/04/11 - xda-developers

  4. #3
    Junior Member JoeSchmoe007's Avatar
    Join Date
    May 2011
    Posts
    6
    As was suggested on another forum I got full GRI40 (2.3.3) version for the N1 at HTC - Developer Center

    Then I flashed it using fastboot as 3 separate pieces. Then I upgraded to 2.3.4.

  5. #4
    Android Lurker DudeRandom21's Avatar
    Join Date
    Aug 2011
    Posts
    0
    That's cool but the only thing is that now you don't have root access if you would have done it like I said you would but it's no big deal cause since your bootloader is unlocked you can root 2.3.4 if you want.

  6. #5
    Junior Member bahhaziz's Avatar
    Join Date
    May 2011
    Posts
    14
    i'm still stuck with 2.2 and my nexus one does not receive any update of any application, for example, it still have google maps v4.3.0
    i have data plan and wifi home, always connected to the net.
    why there is no desktop manager beside OTA for android like the itunes for apple or the blackberry desktop manager for blackberry to get updates and manage the phone using the computer?

  7. #6
    Junior Member JoeSchmoe007's Avatar
    Join Date
    May 2011
    Posts
    6
    Quote Originally Posted by bahhaziz View Post
    i'm still stuck with 2.2 and my nexus one does not receive any update of any application, for example, it still have google maps v4.3.0
    i have data plan and wifi home, always connected to the net.
    why there is no desktop manager beside OTA for android like the itunes for apple or the blackberry desktop manager for blackberry to get updates and manage the phone using the computer?
    If you want to receive update for Google Maps you need to set up Android Market account on your phone. Then check for updates for the apps via Market application on the phone

  8. #7
    Junior Member bahhaziz's Avatar
    Join Date
    May 2011
    Posts
    14
    I got some updates for my apps, but still having the OS 2.2 version. do I have to register my phone with google or do something to receive the OTA update for my OS?
    my phone is all time connected to the net.

  9. #8
    Android Lurker danger-rat's Avatar
    Join Date
    Mar 2011
    Posts
    0
    Quote Originally Posted by bahhaziz View Post
    I got some updates for my apps, but still having the OS 2.2 version. do I have to register my phone with google or do something to receive the OTA update for my OS?
    my phone is all time connected to the net.
    Where did you get your phone from?

  10. #9
    Android Lurker DudeRandom21's Avatar
    Join Date
    Aug 2011
    Posts
    0
    Quote Originally Posted by bahhaziz View Post
    I got some updates for my apps, but still having the OS 2.2 version. do I have to register my phone with google or do something to receive the OTA update for my OS?
    my phone is all time connected to the net.
    Go to settings -> about phone and look at the bottom for build number tell me what it says. I suspect you may have a vodafone ROM which means you will need to passimg to get to stock then you will be able to update.

  11. #10
    Junior Member bahhaziz's Avatar
    Join Date
    May 2011
    Posts
    14

    from amazon

    Quote Originally Posted by danger-rat View Post
    Quote Originally Posted by bahhaziz View Post
    I got some updates for my apps, but still having the OS 2.2 version. do I have to register my phone with google or do something to receive the OTA update for my OS?
    my phone is all time connected to the net.
    Where did you get your phone from?
    I got the phone unlocked brand new in its original box last month from amazon.com (sold and shipped by amazon) using it right now on T-mobile network.

Page 1 of 2 12 LastLast

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Ok..finally need some help.
    By androidlover in forum Samsung Galaxy
    Replies: 1
    Last Post: 09-07-2011, 05:25 AM

Search tags for this page

android assert failed get prop ro build date utc
,
android update assert failed
,
apply patch build.prop
,
assert fail battery warning.apk
,

assert failed apply patch check( /system/build.prop

,

assert failed file getprop system build.prop ro.build.fingerprint

,

assert failed file getprop( /system/build.prop ro.build.fingerprint )

,

assert failed getprop android

,
assert failed getprop ro.build.date.utc
,
failed update asset build prop
,
file-getprop
,
google update android assert failed: file getprop(/system/build.prop
,

incredile s install rom assert failed: file getprop

,

nexus s assert failed: apply patch check

,
system/app/vvm.apk thunderbolt ota failed
Click on a term to search our sites for related topics.
Android Forum