I have Nokia 616 in my car, I can pair over BT my P970 and Nokia 616, but downloading contacts fails, Nokia gives General error.
Probably the problem is in BT version. Nokia is old and does not understand BT3 from LG. Is there any way to put LG to speak old BT version?