First off, hoping this is the right place to post this;
More importantly, my phone is a Canadian GS4 Bell SGH-i337M.

Just one or two days ago (before I flashed the 4.4 KitKat Beanstalk rom) my phone worked fine. Receive a call, make a call, no problems or hangtime.
That was on CyanogenMod, and every rom before it. Now, I get a call and it pops up with the options to decline, decline with a message or answer. Neither of the buttons trigger anything, solely responding with animation. I try to call someone and as soon as I press the call button, the screen goes black for about 10 seconds. When the phone dialog finally pops up, the call works but nobody can hear me and I hear nothing either. None of the options, such as mute, hold, etc work except the End Call button.

So, I realize my phone stopped working from the transfer Beanstalk (which might I add is flawless besides this issue).
I went back to my restore of Cyanogen after using the Factory Reset on TWRP, still the phone has the exact same problems.

So now I'm lost and my next idea is to keep switching roms, though I would really love to stick with Beanstalk 4.4.
Can anyone suggest anything to me?

UPDATE: Just tried making an outgoing call again, crashed my phone to boot screen, or it restarted or something.
Any answers are welcome because I need to solve this ASAP, currently looking for a job and my phone needs to be able to answer incoming calls.