Samsung Note 2 Unresponsive

This is a discussion on Samsung Note 2 Unresponsive within the Rescue Squad Help forums, part of the Android Rescue Squad Support Forum category; A few days ago, my daughter's Samsung Note 2 more or less stopped working. I say "more or less", as I could (before the battery ...

Results 1 to 2 of 2
Like Tree1Likes

Thread: Samsung Note 2 Unresponsive

  1. #1
    Android Lurker docaxie's Avatar
    Join Date
    Aug 2014

    Samsung Note 2 Unresponsive

    A few days ago, my daughter's Samsung Note 2 more or less stopped working. I say "more or less", as I could (before the battery ran out) press the power button and get to the screen where it says "Samsung Galaxy Note". However, it got stuck there. No blinking, no turning off. Once turned on, the power button didn't work so to turn the phone off I had to remove the battery. I read on several websites that the power button could stick, so I've tried to smack it and I've tried to press it quickly and repeatedly, but with no result.

    When I try to charge the phone, the screen shows the "charging battery"-symbol (the battery with a ring in the middle), but the ring is static, not animated. I can turn the screen off by pressing the power button for a long time, but the screen comes on by itself a few seconds later. Plus, the battery isn't charging. I've tried to connect the phone to a computer by USB, but the computer doesn't acknowledge that there's anything plugged in (with one exception, which I will get to below).

    The phone stopped working while being used at the beach, so obviously I've tried to remove any sand by blowing at wherever I figure sand could get in. However, my daughter claims the phone had been giving her a hard time already before it stopped working, freezing every now and then.

    I've tried power + volume down + home. Sometimes it takes me to the screen where I can choose to install custom OS, sometimes it doesn't. From this screen, if I pick "cancel", the phone just goes back to the start up screen. If I pick "continue" I get to Odin mode. If the phone is connected to a computer when I do this, the computer will recognize that there's something plugged in (it will start downloading drivers), but the phone doesn't show up in the Explorer. On the phone's screen it says "Odin mode // Product name: // Custom binary download: No // Current binary: Samsung official // System status: Custom", ie the phone doesn't seem to know it's own name. If left alone, the phone will stay on this screen for hours.

    I've also tried going into recovery mode by pressing power + volume up + volume down, but nothing happens.

    Is there any way to fix this? And if not, is there any way I can rescue the files (mostly photos and music) she has stored on her phone's internal memory card?

  2. is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Super Moderator cali's Avatar
    Join Date
    Sep 2011
    329 times
    Welcome to the site. Hope someone can help with this problem.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. Replies: 1
    Last Post: 08-02-2013, 07:28 PM
  2. Replies: 0
    Last Post: 07-09-2013, 11:45 AM
  3. Replies: 0
    Last Post: 04-18-2013, 02:39 PM
  4. Replies: 0
    Last Post: 10-22-2012, 09:35 AM
  5. Replies: 2
    Last Post: 05-31-2012, 02:44 AM

Search tags for this page

android note 2 unresponsive
current binary say samsung official

galaxy note 2 unresponsive

note 2 stuck on battery
samsung note 2 unresponsive
unresponsive galaxy note 2
unresponsive galaxy note 2 with full battery
Click on a term to search our sites for related topics.
Android Forum