Hi, I have an ZTE blade with the custom rom 360 mix installed on it. Recently, I discovered that the wifi sleep policy (under wireless & networks->wifi settings->advanced) always remains on 'never'. Even when I change it to 'when screen turns off', it reverts to 'never' after the screen turned off. I even changed roms, but this problem resists. Is there a way to change this annoying problem in my google-account settings or something? Needless to say that this problem drains my battery too fast for my taste.

thanx in advance