Okay, I searched online for quite a while before I got my Captivate and saw I could tether it (after I rooted it of course) by setting up a proxy. I tried that, and it worked but the connection sucked. I poked around with minicom (and wvdial ) and found that I could tether without the proxy by using wvdial.

You'll need to root the phone, and have the root file that allows you to tether the phone on via the Samsung icon.
{Edit: USB debugging should be set to "ON"}
{Edit missed a glitch in the script...SORRY!!! Should be S0=0 NOT S0-0 }
Create the following wvdial.conf file

[Dialer Defaults]
Init2 = AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
Modem Type = USB Modem
Init1 = ATZ
Modem = /dev/ttyACM0
Baud = 460800
ISDN = 0
Stupid Mode = 1
New PPPD = yes
Phone = *99#
Password = test
Username = test

Launch wvdial and you're ready to roll!
I'm using that method right now!


(I'm using OpenSuse 11.1 with a Captivate tether with my old Nokia USB cable! )

{Edit: Your'e setting MIGHT be a bit different. Root and tether your phone, with USB debugging on, run Minicom and hit Ctrl-Z and A and use the Initialize modem function in the menu. Then look up the settings in the menu under Init string! }