Please Help. having trouble installing new ROM

This is a discussion on Please Help. having trouble installing new ROM within the Samsung Captivate Hacking forums, part of the Samsung Captivate category; Hey guys I started with a rooted Cappy runnings AT&T version of 2.2 I want to install Dorian's UGJK3 ROM. I ran the JF6 Eclair ...

Results 1 to 4 of 4

Thread: Please Help. having trouble installing new ROM

  1. #1
    Junior Member BLKZILLA's Avatar
    Join Date
    Dec 2010

    Please Help. having trouble installing new ROM

    Hey guys

    I started with a rooted Cappy runnings AT&T version of 2.2

    I want to install Dorian's UGJK3 ROM.

    I ran the JF6 Eclair build ODIN3 One-Click restore and reverted to Eclair.
    I downloaded the SGS One Click Root file but I cannot get it to run on my Windows 7 machine or XP. *errors*

    I tried to use a manual method i found to root my phone but I was unable to boot into recovery mode. holding down both power volume buttons and the power button just wants working. my phone just cycled between the att world phone screen and a black screen.

    I decided to go back to AT&Ts version of 2.2 and used this thread to root. it appeared to be successful. supersuser app showed up

    Installed ROM manager, Flash Clockwork Recovery mod. & moved Dorian's ROM to my phone.

    Used ROM Manager to reboot into recovery mode and there isnt an option to install zip from SD card. When I click on reinstall packages I get an error that files have invalid signatures.

    Please tell me what I'm doing wrong.

  2. is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Senior Member Fluffy_attdroids's Avatar
    Join Date
    Feb 2011
    Make sure you have the Windows Drivers for your USB

    Install those and then try the steps.. The steps in Dorians thread are very good and work correctly..

    If you have the drivers.. Make sure you enable USB Debugging again after you restore.. That may also be your problem..

    Also the reason you do not see the option is your in the wrong reboot mode. Your in the Samsung boot loader.. You need to be in the CWM boot loader..

    Boot normally into your phone again.. Install CWM then select your phone type.. This will create an on your SD card.. Reboot into recovery and then select Install

    This will install the correct CWM bootloader.. Once you have that you should then be able to see Install from Zip..

  4. #3
    Junior Member BLKZILLA's Avatar
    Join Date
    Dec 2010
    uninstalled the drivers I had and installed the one from your link (thanks!) and now I cant even get the damn thing into download mode....


    I swear my phone is infected by devils!

    Flashing the ROM is/was my last resort before drop kicking this thing into the nearest lake.

    I'm going home I'm going to try again from there.

  5. #4
    Super Moderator Dorian's Avatar
    Join Date
    Jan 2011
    between 850-1900MHz
    71 times
    Under your battery, what does it say your build number is? Some Captivate's don't come with "3 button download mode". In that case, you can use "adb reboot download" and flash it that way.

    1008 builds and up have issues with download mode to some extent. 1007 and earlier have 0 issues with 3-button mode. I'm guessing yours is at least a 1008 or higher.

    EDIT... The reason you can't get into a proper recovery is because on UCKB1 stock Froyo 2.2, it uses 3e recovery that requires signed packages. Flash back to UCJF6 with ODIN One click then do this...

    1. Go to Settings --> Applications --> Development --> check USB Debugging.
    2. Connect your phone to your computer and Windows will install new drivers for a Samsung Android ADB Debug Bridge and a USB Mass Storage Driver.
    3. On your phone, drop the notification bar and select use USB Storage, then enable it.
    4. On your computer you should see a popup where you can use the phone storage.
    5. Drop this - - onto the internal storage. Don't put it in any folders or anything...
    6. On your phone disconnect USB Storage.
    7. Shut down your phone.
    8. Press Volume Up, Down and Power and hold it till you get into Recovery Mode. It should be blue text.
    9. Use your volume buttons to select flash Power button is the select button. Now your phone will reboot.
    10. Do step 9 once more. Now it will reboot into CWM Recovery. CWM Recovery will have green text.
    11. Now go to flash zip from SD card, then choose zip from SD card.
    12. Now find the zip of my ROM.... and select it with the power button.

    If you have any trouble, let me know! I really recommend you use XWJS8 if you're going to stay on Froyo though. It's much more stable. Here's a link to the XWJS8 zip. It's installed the same way as UGJK3. You would just select XWJS8 instead of UGJK3 to flash in ClockworkMod recovery.

    Need Assistance? Contact me at

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. 2.2
    By TMODroids User in forum General Android OS
    Replies: 0
    Last Post: 12-07-2010, 08:42 AM

Search tags for this page

avatar rom invalid signature

how to flash clockworkmod recovery on samsung captivate ucjf6

install rom says invalid signature
invalid signature captivate root
invalid signature installing stock rom

invalid signature rom flash

invalid signature samsung captivate root
invalid signature when installing rom
rom installer eclair
rom says invalid signature
samsung captivate signature problem rom
samsung infuse froyo reinstall packages
signature problem in rom installation
ucjf6 root with odin
when installing rom get invalid signature error
Click on a term to search our sites for related topics.
Android Forum