Help Needed with SGS2 Accelerometer, Gyroscope Sensor, and Magnetic Sensor

This is a discussion on Help Needed with SGS2 Accelerometer, Gyroscope Sensor, and Magnetic Sensor within the Samsung Galaxy S2 forums, part of the Samsung Android Phones category; Hello everyone, I am new here so i hope i am posting in the right place, So i got my SGS2 last month,i love it,everything ...

Results 1 to 7 of 7

Thread: Help Needed with SGS2 Accelerometer, Gyroscope Sensor, and Magnetic Sensor

  1. #1
    Android Lurker Zeinia's Avatar
    Join Date
    Jan 2012
    Posts
    1

    Help Needed with SGS2 Accelerometer, Gyroscope Sensor, and Magnetic Sensor

    Hello everyone,

    I am new here so i hope i am posting in the right place,

    So i got my SGS2 last month,i love it,everything seems to be fine,i was learning tips and tricks everyday and loving it more and more,but then i noticed that in all the youtube videos when they rotate the phone,screen would rotate automatically,everytime,and mine didn't do that much frequently,it had like its own will and it would rotate sometimes and sometimes it would not,since i wanted my qwerty keyboard in landscape mode so i started looking into it,(the auto rotation was turned on)

    First thing i found was horizontal calibration,tried it,it will go on for hours with out saying "calibrated" i finally had to take out the battery to switch off the phone and then re start it,with no different results.

    Then i found *#0*# test,tried that,first the magnetic sensor was moving had a blue or a green line on it and i think number "2" was written on it,i read that when i rotate the phone the x,y,z readings should change ,but they weren't ,i tried image test and after rotating phone for a few times the values started changing and the image rotated,i went back to home screen and text screen also rotated and i was happy,but then after half an hour or so i picked up my phone and it again wasn't auto rotating,i did *#0*# again and this time magnetic sensor had green light on and number 3 and it was moving but when i did the image test it didn't move at all.
    So finally i thought i need to put it for calibration again no matter ho long it takes,i did it again,took hours and hours all my battery was drained,and when i plugged it and re started,auto rotation was totally gone and now when i do *#0*# the sensor has a red light saying "need for calibration",accelerometer sensor has no readings and gyro selt test says "FAIL" (i don't even understand whats gyro selt test :s )

    I am really freaked out here,did i damage something? plz plz plz help me,i tried reading through the forums but half the lingo i don't understand ,plz be easy with the language,i am begging for help,my family was really not happy i got this expensive phone,and now if something happens to it sorry for the long post,i'll anxiously wait for replies.

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Android Lurker antihero's Avatar
    Join Date
    Jan 2012
    Posts
    5
    Thanked
    1 times
    Hi, I have the same problem but mine is caused from hardware issues because I dropped my phone..I've read multiple fixes and yours seems fixable.start with a factory reset...and If that doesn't fix it turn auto rotate off ...reboot then turn auto rotate back on. Also don't use live wallpaper because some messes the resolution settings up,also do some game apps.

    Sent from my PG86100 using Android.net

  4. #3
    Android Lurker icelobber's Avatar
    Join Date
    May 2012
    Posts
    1
    Hello,
    i had problems with my Samsung GT I9001, the compass would never show the correct settings.
    Then i read some stuff and enabled some Encryption. Now it works beautifully.
    But even still when i use the *#0*# it show the Need for calibration with 0 now and sometimes 2.
    I also got a Compass needs calibration message for an instant yesterday and then it was gone.
    Also, You could test the compass (and other sensors) correctly using a tool from Zausan. Available on Google Play link
    https://play.google.com/store/apps/d...=search_result
    thanks,
    APS

    Quote Originally Posted by Zeinia View Post
    Hello everyone,

    I am new here so i hope i am posting in the right place,

    So i got my SGS2 last month,i love it,everything seems to be fine,i was learning tips and tricks everyday and loving it more and more,but then i noticed that in all the youtube videos when they rotate the phone,screen would rotate automatically,everytime,and mine didn't do that much frequently,it had like its own will and it would rotate sometimes and sometimes it would not,since i wanted my qwerty keyboard in landscape mode so i started looking into it,(the auto rotation was turned on)

    First thing i found was horizontal calibration,tried it,it will go on for hours with out saying "calibrated" i finally had to take out the battery to switch off the phone and then re start it,with no different results.

    Then i found *#0*# test,tried that,first the magnetic sensor was moving had a blue or a green line on it and i think number "2" was written on it,i read that when i rotate the phone the x,y,z readings should change ,but they weren't ,i tried image test and after rotating phone for a few times the values started changing and the image rotated,i went back to home screen and text screen also rotated and i was happy,but then after half an hour or so i picked up my phone and it again wasn't auto rotating,i did *#0*# again and this time magnetic sensor had green light on and number 3 and it was moving but when i did the image test it didn't move at all.
    So finally i thought i need to put it for calibration again no matter ho long it takes,i did it again,took hours and hours all my battery was drained,and when i plugged it and re started,auto rotation was totally gone and now when i do *#0*# the sensor has a red light saying "need for calibration",accelerometer sensor has no readings and gyro selt test says "FAIL" (i don't even understand whats gyro selt test :s )

    I am really freaked out here,did i damage something? plz plz plz help me,i tried reading through the forums but half the lingo i don't understand ,plz be easy with the language,i am begging for help,my family was really not happy i got this expensive phone,and now if something happens to it sorry for the long post,i'll anxiously wait for replies.

  5. #4
    Super Moderator cali's Avatar
    Join Date
    Sep 2011
    Posts
    4,830
    Thanked
    329 times
    Welcome to the site icelobber. Thanks for posting the link to the tool. Hope the OP was able to resolve her problems.

  6. #5
    Android Lurker kenw2121's Avatar
    Join Date
    Jun 2012
    Posts
    1
    I just rotated my phone in random direction to calibrate magnetic sensor.

  7. #6
    Android Lurker aravind777's Avatar
    Join Date
    Dec 2012
    Posts
    1

    Try this out . it may work!!!

    hi every one ,
    i am happy to share my experience with gyroscope sensor problem with my samsung s2.

    i also faced the issue like gyroscop sensor not workingproperly .so i was not able to play some games
    then i tried may things but not working .
    Finally i removed the battery and put again then switched on the mobile . everything is working fine . .








    UOTE=Zeinia;135793]Hello everyone,

    I am new here so i hope i am posting in the right place,

    So i got my SGS2 last month,i love it,everything seems to be fine,i was learning tips and tricks everyday and loving it more and more,but then i noticed that in all the youtube videos when they rotate the phone,screen would rotate automatically,everytime,and mine didn't do that much frequently,it had like its own will and it would rotate sometimes and sometimes it would not,since i wanted my qwerty keyboard in landscape mode so i started looking into it,(the auto rotation was turned on)

    First thing i found was horizontal calibration,tried it,it will go on for hours with out saying "calibrated" i finally had to take out the battery to switch off the phone and then re start it,with no different results.

    Then i found *#0*# test,tried that,first the magnetic sensor was moving had a blue or a green line on it and i think number "2" was written on it,i read that when i rotate the phone the x,y,z readings should change ,but they weren't ,i tried image test and after rotating phone for a few times the values started changing and the image rotated,i went back to home screen and text screen also rotated and i was happy,but then after half an hour or so i picked up my phone and it again wasn't auto rotating,i did *#0*# again and this time magnetic sensor had green light on and number 3 and it was moving but when i did the image test it didn't move at all.
    So finally i thought i need to put it for calibration again no matter ho long it takes,i did it again,took hours and hours all my battery was drained,and when i plugged it and re started,auto rotation was totally gone and now when i do *#0*# the sensor has a red light saying "need for calibration",accelerometer sensor has no readings and gyro selt test says "FAIL" (i don't even understand whats gyro selt test :s )

    I am really freaked out here,did i damage something? plz plz plz help me,i tried reading through the forums but half the lingo i don't understand ,plz be easy with the language,i am begging for help,my family was really not happy i got this expensive phone,and now if something happens to it sorry for the long post,i'll anxiously wait for replies.[/QUOTE]

  8. #7
    Super Moderator cali's Avatar
    Join Date
    Sep 2011
    Posts
    4,830
    Thanked
    329 times
    Welcome to the site aravind. Thanks for posting your experience.

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Hello, Looking for Help With the Magnetic Sensor
    By Kenty in forum Rescue Squad Help
    Replies: 1
    Last Post: 08-11-2012, 02:35 PM
  2. Hello, Looking for Help With the Magnetic Sensor
    By Kenty in forum Introductions & Site Assistance
    Replies: 0
    Last Post: 08-11-2012, 12:44 PM
  3. Replies: 0
    Last Post: 07-11-2012, 06:10 PM

Search tags for this page

accelometer problem s2
,
galaxy s2 gyro self test fail
,
galaxy s2 magnetic sensor calibration
,

gyroscope calibration galaxy s2

,
gyroscope not working galaxy s2
,
gyroscope sensor fail galaxy s2
,
how to calibrate gyro horizontally in gt i9100 by code
,
how to calibrate samsung s2 leval sensor by code
,
my samsung s2 gyroscope calibration not working solution
,
s2 accelerometer not working
,

s2 i1900 rotation sensors are not working

,
s2 sensor not working
,
samsung galaxy s2 accelerometer sensor settings
,
samsung galaxy s2 gaming sensor on working correctly
,

what is gyroscope calibration galaxy s2

Click on a term to search our sites for related topics.
Android Forum