Love the Play, but my USB is having problems...

This is a discussion on Love the Play, but my USB is having problems... within the Sony Xperia Play forums, part of the Sony Android Phones category; I love my Xperia Play but my USB port is having trouble keeping a connection so I had to order a replacement from Verizon last ...

Results 1 to 4 of 4

Thread: Love the Play, but my USB is having problems...

  1. #1
    Xperia Lurker Alazam's Avatar
    Join Date
    Jun 2011
    Location
    Southeast Missouri USA
    Posts
    25

    Love the Play, but my USB is having problems...

    I love my Xperia Play but my USB port is having trouble keeping a connection so I had to order a replacement from Verizon last night. I really hope the next one works right for more than 10 days...

  2. Android.net is the premier Android Forum. Registered users do not see these ads. .

  3. #2
    Super Moderator GameBoiye's Avatar
    Join Date
    May 2011
    Posts
    288
    There's always going to be a few bad phones when they had to make so many so fast. Sucks that you got a bad one. Lets all hope that the next one is good.

  4. #3
    Xperia Lurker Alazam's Avatar
    Join Date
    Jun 2011
    Location
    Southeast Missouri USA
    Posts
    25
    I got my replacement phone and it seems to be working much better than the first one. The USB is functioning as it is supposed to and the battery seems to charge faster and last longer as well...

  5. #4
    Super Moderator GameBoiye's Avatar
    Join Date
    May 2011
    Posts
    288
    Nice to hear you got it sorted out.

Remove Ads

http://www.scramblerducati.org/

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Android Forum